1

My browser is in English and I have removed all other languages, but when I go to the console and look up navigator.language it shows a value of "bg-BG" and navigator.languages is ["bg-BG", "en"].

I tried normal and hard reloads of the page, restarting Chrome, clearing the browsing data, even restoring the settings to their original defaults. Then I decided that if not removing it I can maybe move it lower if I add Bulgarian as a language and move that lower and now navigator.languages is equal to ["bg-BG", "en", "bg"].

If I add a new person to Chrome they don't have "bg-BG" in their navigator.languages and their default is English.

edit: I found a way that temporarily fixes it. If I select a language and pick Move to the top it will go above bg-BG, but newly added languages will still go under it. So it's still in the list in the languages settings, just hidden and unselectable.

3
  • Change it using standard settings UI ( goto chrome://settings/?search=lang).
    – JosefZ
    Jan 13 '19 at 14:01
  • That's what I've been doing. I'm not aware of other ways to change the language.
    – Nadroev
    Jan 13 '19 at 14:10
  • Do you have the issue in Chrome 73 ? Read crbug.com/784740 ? Jan 14 '19 at 19:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.