2

On Linux, tree and pstree commands show tree-like hierarchy of directories and processes respectively.

Their output usually includes the characters | and _ which are used to draw the tree structure.

When I use PuTTY to ssh into my instances (Ubuntu 18.04 and Centos 7), the output show these characters as â.

If I use cmd to ssh into my instances and run the same command, the output is rendered correctly.

How do I fix this in PuTTY?

1 Answer 1

1

I have recreated your problem. It occurs with many character sets different than UTF-8, when the server uses UTF-8. Even if UTF-8 is not the right set in your particular case (but it probably is), this is the option you should change.

In PuTTY configuration the option is under Window→Translation, Remote character set.

config window

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .