0

I'm currently using Windows 7 Ultimate, 64-bit as a server. I use many applications like SSH, FTP server, VNC, Apache/PHP, Webdav Server.

All of a sudden, my apps became completely inaccessible from other computers on the same network.

What I've tried so far:

  • disabling Windows Firewall;
  • resetting Firewall, netsh, flushdns, TCP/IP;
  • allowing my apps and ports through Windows Firewall, when enabled;
  • disabling password-protected sharing;
  • enabling file sharing in Windows;
  • enabling WebClient (for WebDav);

Nothing works. I can't use VNC, FTP, WebDav. Nothing. Only thing that works is ping my server address. All packets received.

How you can help solve my problem:

  • Suggesting settings for me;
  • Suggesting apps so I can diagnose it myself;
  • Suggesting links;

I need my server to be visible. I have to access it from the other room and do my work. When I try to reach any of these apps with other computer, I get something like "connection error", "not found". Something like that.

  • Try to restore Windows to a System Restore Point from before this happened. – harrymc Jan 14 at 10:39
  • I don't have that enabled because I don't have much disk space. – G. L. Jan 14 at 10:40
1

Aff.

The solution was really something that makes me feel tired.

I did 3 things. I don't know which of them actually worked, but I think that thing number 3 actually solved it.

1) I've uninstalled windows updates number KB4480970 and KB4480960

2) I've installed update number KB4487345

3) I've added manually all my apps by going to Local Security Policy, Windows Firewall with Advanced Security, Inbound rules.

  • Most likely it was installing KB4487345 that solved your problem. It fixes a known issue introduced by KB4480970. See this SU answer – Twisty Impersonator Jan 15 at 0:16
0

Since System Restore is unfortunately disabled, I can only propose doing Repair Install.

Take first a backup image of the disk, not with the buggy Windows Backup, just in case.

  • I won't do that. That's the dirty and quick way to solve it. I want to fix it. It's like formatting and trying again. I know how to do both. – G. L. Jan 14 at 12:02
  • 1
    I'm at work right now but it happened after I've performed a Windows Update. Probably due to this update: sevenforums.com/network-sharing/… – G. L. Jan 14 at 12:04
  • As soon as I get home, I'll post the results. – G. L. Jan 14 at 12:04
  • 1
    Repair Install is not like formatting - with in-place upgrade you keep all your installed products and almost all system settings. Microsoft has lately produced some lousy updates (although not so many for Windows 7), so it's worthwhile to first check Windows Update history. – harrymc Jan 14 at 12:09
0

It turns out all my problems came back.

After restarting the router, everything's solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.