10

I have 2 SSD's; 1 for my OS' (will refer to as the "OS drive") and the other for data (data drive). I have dual booted Windows 10 and Ubuntu 18.04. The Windows side seems perfectly fine. On Ubuntu, however, frequently (not always) I won't be able to save data onto the SSD that holds data because Ubuntu says it is read-only. This is from startup onwards. Again, this only frequently happens and not every time so sometimes it is mounted correctly and other times not. I am able to save data on the other ("OS drive") drive though.

The drives are of different file systems. My "OS drive" (mounted at /boot/efi) is of FAT32 while my "data drive" (mounted at /mnt/9ACC1AC5CC1A9C17) is NTFS.

df -Th enter image description here

cat /proc/mounts enter image description here

This image shows that, at this point, my "data drive" is read-only ("ro").

I've run the command I grabbed from this answer to remount as read-write ("rw").

mount -o remount,rw /dev/disk/by-uuid/9ACC1AC5CC1A9C17 /mnt/9ACC1AC5CC1A9C17/

Getting the params from "disk": enter image description here

After this, cat /proc/mounts sees that the drive is now in read-write mode: enter image description here

...but I still cannot seem to write to the drive. The same command of touch fires back: No such file or directory.

enter image description here

7 Answers 7

9

Just to also have the additional piece of information here.

Windows, if you "shutdown" does not actually shut down most of the time, but only hibernates.

Windows Hiberation

The fix for people who use a dual boot is also in this thread.

  1. Right click the Windows start menu button and choose Power Options.
  2. Click on Choose What the Power Button Does.
  3. If there is a Windows UAC shield at the top with Change Settings That Are Currently Unavailable, click it and choose Yes or enter your password to reopen the dialog with administrative privileges.
  4. At the bottom below Shutdown Settings, it will say Turn on Fast Startup (recommended). Deselect the option and press Save Changes.

This should solve the issue, as it properly unmounts the drive from Windows and allows it to be mounted as rw in Linux.

I came here, because I intermittently had an issue with Steam and could not add my games library to it, as I got the error:

"New Steam library folder must be on a filesystem mounted with execute permissions."

This happend on Ubuntu 18.04.2 LTS. Games were on a NTFS formatted drive that was used by both Windows 10 and Ubuntu.

The above solution safes you the hassle of having to think of holding down the "Shift" key all the time, while you shut down your PC.

1
  • Thanks for this info. Have been fighting repeated intermittent issues with data access on my designated data drive with my dual boot, and I finally have an explanation and hopeful fix. (We'll see if it worked next time I boot Ubuntu!) Sep 19, 2020 at 21:23
12

In my case running following command fixed the issue. It removes log files created my windows which are not cleared properly unless windows is shutdown completely.

sudo ntfsfix /dev/sdxX # where x is HDD (in my case it was "a") and X is drive number (in my case it was "7"), so I wrote /dev/sda7
3
  • 2
    +1 thanks it works for me I have installed two OS in two different SSD first one contains windows and the second one contains Linux mint after removing the first SSD and only run Linux then I face this issue (read-only file system) with my HDD which I have used to save my data. thanks again, bro :) Jan 15, 2021 at 17:52
  • 1
    Thanks! I have tried two other solutions but only this one worked like a charm! Dec 13, 2021 at 18:02
  • Man, thanks a lot!
    – Romanzhivo
    Mar 16 at 12:16
3

Perform a full Windows shutdown.

A full Windows shutdown (without hibernation) will get Windows 10 or 8 drives to mount with full read and write access on Linux. To perform a full shutdown, press and hold the Shift key while you press the Shut down button on your Windows 10 or 8 OS. You can also restart Windows and reboot into your Linux distribution. In both the full shutdown and restart cases, Windows won't hibernate, so you'll be able to access the Windows drive with read/write access in Linux.

You need to do this every time you want full access of the Windows partition(s) from Linux.

3

If you are in ubuntu and you have already mounted the NTFS Partition, do the following

  • Unmount the Ntfs partition by running sudo umount -a
  • Run sudo ntfsfix /dev/sdaxx (for example /dev/sda3) to get the partition to mount with full read/write access
    Note: If the prartition is not mounted skip step 1

And you will see the output as shown below

Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sda3 was processed successfully.
2

I have found an answer (although it does not give an explanation) here with the solution to make sure Windows is completely shut down. I booted into Windows, shut down holding the SHIFT key. When I booted into Ubuntu, everything seemed fine

0
  1. Unmount the NTFS partition by running

    sudo umount -a
    
  2. Run

    sudo ntfsfix /dev/sdaxx    (for example /dev/sda3) 
    

    to get the partition to mount with full read/write access.

See also this answer here by gumisirizab1.

-1

I had same issue. Turn on fast BIOS from your BIOS settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.