0

Every day when I resume my laptop from sleep mode, I notice the internet seems to be very sluggish.

However, just by toggling my wifi adapter on and off, the speed increases by 10x - I took the following screenshots of when I applied the "fix" today:

So why does this consistently happen and how to fix this once and for all?

I'm running Windows 10.0.17134 Pro on a Surface Pro 4.

3
  • Sounds to.me your adapter is.not fully wakibg up from sleep state. I speculate this is a driver or firmware issue.
    – davidgo
    Jan 15 '19 at 0:09
  • From my perspective, this sounds like another variation of the following problem: When I hibernate or turn off/on my Windows 10 PC, the NIC stops working. Some devices are more suseptible to problems when they "awake" from sleep within a Windows 10 operating system, and WiFi adapters seem to be at the top of the list. Personally, I never put my laptop to sleep. It is either powered-on, or completely shut down with Fast Startup disabled. Give that a try, and your problems are likely to disappear.
    – Run5k
    Jan 15 '19 at 4:10
  • First thing to try: install the latest drivers for your hardware. Jan 15 '19 at 4:38
0

Windows 10 includes the USB selective suspend feature that lets you automatically put USB devices in a very low-power state when they're not actively in use. It's an important feature because it helps prolong battery life on your laptop or tablet, but it may also cause problems with certain peripherals connected to your PC.

If a USB device isn't working correctly, you can try to disable selective suspend on Windows 10. That may cause your computer to draw more power, but it may help to identify and fix the problem as well.

How to disable USB selective suspend

If you're having connectivity issues with USB peripherals on Windows 10, use these steps to disable the USB selective suspend feature.

Important: It's only recommended that you change this particular setting when you're experiencing problems with a USB device. Otherwise, you should leave the option enabled.

  1. Open Control Panel.
  2. Click on Hardware and Sound.
  3. Click on Power Options.
  4. Under "Preferred plan," click the Change plan settings link for the plan you're currently using. (If you change the settings on the power plan that isn't active, this won't work.)

enter image description here

  1. Click the Change advanced power settings link.

enter image description here

  1. Expand USB settings.
  2. Expand USB selective suspend setting.
  3. Select Disabled from the drop-down menu.

enter image description here

  1. Click Apply.
  2. Click OK.

If you're changing the settings on a laptop or tablet, you'll see two options: On Battery and Plugged in, so make sure to change those settings accordingly.

Once you complete these steps, Windows 10 will no longer power off USB devices connected to your computer, which can fix any problem you may have as a result of this feature.

Side Note: also check the wireless settings there to see if you get that option too.

1
  • It's a Surface Pro 4. I doubt the network adapter is connected using USB, but the "Wireless Adapter Settings" might be the key here. Nov 8 at 4:20
0

It's a common problem with Surface laptops.

Here are some things you can try:

  1. Go to the hardware manager -> network adapter -> Intel AX201 -> Advanced -> MIMO power save mode -> Change "Auto SMPS" to "No SMPS". While this resulted in the bug occurring less frequently, only changing the setting to "Static SMPS" (-> disabling MIMO) eliminated the problem entirely for me.

  2. (Optional) Go to the Windows Settings App -> System -> Power & Sleep -> When my PC is asleep and on battery power, disconnect from network -> Change "Never" to "Always"

Source: https://www.reddit.com/r/Surface/comments/dp96pb/psa_workaround_for_slow_wifi_after_waking_from/

It might be already fixed and all you you need to is to simply install the latest drivers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.