Sometimes the chrome browser on my ubuntu 18.04 box will have the UI crash, and then the VM becomes completely unresponsive.

I have to restart the VM entirely to bring it back up.

This has been happening several times and I am losing my unsaved work every time this happens. Is there a way to find out what is causing this and fix it?

For the time being, I am avoiding Chrome, but I'm not sure if this issue is limited to just the browser (So far Firefox has been fine).

Here is a screenshot of the VM when the crash occurs

  • Workaround, for the record: ALT-F4 the unresponsive Chrome, even if no effect is visually noticeable due to the corrupted screen that actually works (for me, anyway). Then CTRL-ALT-ENTER (or whatever your key combination is) to switch VMWare from full screen to window mode - and then again to switch back immediately. My screen now is usable again, this reset the graphics.
    – Mörre
    May 6, 2019 at 6:41

5 Answers 5


Disable hardware acceleration! The performance gets a little hit, but it's not that bad after all.

Chrome settingsAdvancedSystem → Disable Use hardware acceleration when available!


Chrome also hangs physical systems due to high memory consumption and sometimes face issues when using the GPU. You might have some luck using the tips from this AskUbuntu thread, among which are disabling hardware acceleration in the Chrome settings and disabling GPU Rasterization.

As these problems are sometimes fixed by better/newer GPU drivers, this might go away if VMWare releases some newer drivers later on.


I have the same issue with my Ubuntu 18.04 running in vmware. Chrome hangs, followed by a complete freeze of the VM. After a forced reboot the system logs show those lines:

Aug 20 11:41:09 ubuntu kernel: [58480.901168] [drm:vmw_cmdbuf_work_func [vmwgfx]] ERROR Command "SVGA_3D_CMD_DX_DESTROY_SHADERRESOURCE_VIEW" causing device error.
Aug 20 11:41:09 ubuntu kernel: [58480.901175] [drm:vmw_cmdbuf_work_func [vmwgfx]] ERROR Command buffer offset is 0
Aug 20 11:41:09 ubuntu kernel: [58480.901180] [drm:vmw_cmdbuf_work_func [vmwgfx]] ERROR Command size is 12

I think it is this unresolved bug.


I've started suffering same problem after some Windows 10 update installation. Problem is related to NVidia driver only and VM's running on VMWare player are being freeze when trying to play various videos or gif animations in Skype, Windows Whatsapp and Chrome/Brave. So far only switching off 3D support for VM solves the problem. Please try and let un know how it works for you.


Goto virtual machine settings and uncheck "Accelerate 3D Graphics from 3D Graphic

  • Other answers already suggest this. Do not add answers unless they differ from what has already been presented. Nov 8, 2022 at 4:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .