1

I am using VMware Workstation 12 Player. My host is Windows 10, my guest is Fedora 22.

I want to set up a COM port between the host and guest. The reason is I have an app running in Windows that needs to talk to an app that only runs in Linux.

I followed the instructions posted on VMware website. To summarize:

In the VM:

  • Added a named pipe called \\.\pipe\com12, I have also tried \\.\pipe\com_12.
  • Settings are This end is the server. and The other end is an application., which I think is accurate.
  • The port shows up when the VM boots up as Serial Port 2.

In Windows (host):

  • I used com0com to set up a pair of named pipes in Windows. I have COM10 linked to COM12. Nothing else is using the ports.

On Windows I opened TeraTerm, set it up to use COM10 (but I have also tried COM12), set baudrate to 115200, parity is 'none', 8 data bits, 1 stop bit, no flow control.

On Linux I opened cutecom, set it up to use ttyS2 (Serial Port 2, right?), and matched all other settings.

I tried sending characters from Windows to Linux and the other way around, but I don't see anything. What else do I need to do to get this to work?

1

Ah I figured it out. Since I was using com0com, I didn't need to make a named pipe. This is the process I followed:

  1. Set up a pair of COM ports in Windows using com0com. For me the pair as COM10 and COM12.
  2. In VMware add a serial port:

    • Under Connection select Use physical serial port, and select COM10.

Now in Windows I open RealTerm and connect to COM12. In Fedora I open Cutecom and connect to ttyS2. They can now communicate!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.