0

I have a Dell Zbook 17 G5 laptop with nvme ssd i use for work that i am pulling my hair out to fix this issue i am having. After a fresh boot, if i restart or shutdown (possibly even just log off but i haven't test it), it will stay in the shutdown screen for 7-10 minutes before proceeding to turn off. If i was logged in for 10 minutes already, it will turn off/reboot normally in a couple of seconds.

I've disabled all non-microsoft services, removed the anti-virus, disabled windows defender, checked if page file delete policy is disabled, etc and can't find the issue.

Last resort i found this question and answer here: How can I identify the culprit of my slow Windows shutdown? and recorded 2 performance logs. One is "good" (quick restart since i was logged in for more than 10 minutes) and the other one is "bad" (slow restart since i rebooted as soon as i logged in). I can't seem to find a sure cause, but i am not familiar with the analyzer enough to know what is fishy.

That's why i uploaded both logs in hopes someone can please check them out: https://www.dropbox.com/s/76sowxabh8mndnp/windows_performance_logs.rar?dl=0

Kind regards

  • Have you already tried to disable the Fast Startup function to see if that helps? – Run5k Jan 16 at 0:21
  • @Run5k - Wouldn't that make the system take longer to boot? – Ramhound Jan 16 at 0:31
  • @Ramhound, logically that should be the case. However, it also sounds like it's possible his hardware/OS configuration is having problems that could be related to similar capabilities that the Fast Startup function typically modifies. From my perspective, the principles of "troubleshooting 101" would seem to dictate that it might be wise to eliminate that possibility, since the OP apparently hasn't tried that yet. If the problem persists, it is very easy to turn back on again. – Run5k Jan 16 at 2:04
  • @Run5k Yes that is the first option i disable in any work PC, win10 junk. Also from the performance log and indicators it seems the pc doesn't do any work, it just waits:/ could be a miss-configured service if i were to guess possibly a microsoft one (since i've disabled the others)..i could update to 1809 and hope for the best but i want to stay away longer so microsoft fixes all their bugs – TnF Jan 16 at 2:13
  • Fast Startup absolutely is not "Windows 10 junk". If you have disabled the required files for Windows to boot quickly (i.e hibernation.sys, pagefile.sys, and swapfile.sys) that might explain your performance issues. – Ramhound Jan 16 at 2:29
1

Ok fixed it. So it turns out there is an issue somewhere with the GPClient if you use custom DNS servers, even though you might not be connected to them. My user account is a domain user. In my network settings i had set google dns to bypass the filtering used in the domain network. The problem with this seems the group policy client cannot access the policies set by the domain (even though in my case the policies are empty) and hangs the system until some timeout is gone. I changed back the domain dns to automatic for my network adapter, and then updated the domain group policy by running this command:

gpupdate /force

In order for it to be successful i had to renew the dns with some command i found in the error log in the event viewer, but i would guess a restart would do the job as well. Now i need to find what setting controls this timeout which is absolutely stupid set to like 10 minutes.

  • found it in gpedit.msc, Computer Configuration\Administrative Templates\System\Scripts , Specify maximum wait time for Group Policy scripts – TnF Jan 16 at 9:32
  • This policy setting determines how long the system waits for scripts applied by Group Policy to run. This setting limits the total time allowed for all logon, logoff, startup, and shutdown scripts applied by Group Policy to finish running. If the scripts have not finished running when the specified time expires, the system stops script processing and records an error event. – TnF Jan 16 at 9:34
  • If you enable this setting, then, in the Seconds box, you can type a number from 1 to 32,000 for the number of seconds you want the system to wait for the set of scripts to finish. To direct the system to wait until the scripts have finished, no matter how long they take, type 0. This interval is particularly important when other system tasks must wait while the scripts complete. By default, each startup script must complete before the next one runs. – TnF Jan 16 at 9:34
  • Also, you can use the ""Run logon scripts synchronously"" setting to direct the system to wait for the logon scripts to complete before loading the desktop. An excessively long interval can delay the system and inconvenience users. However, if the interval is too short, prerequisite tasks might not be done, and the system can appear to be ready prematurely. If you disable or do not configure this setting the system lets the combined set of scripts run for up to 600 seconds (10 minutes). This is the default. – TnF Jan 16 at 9:34
  • Also can confirm this is working along with custom dns no issues! You are supposedly need to set Run logon scripts synchronously policy to Disabled as well but i don't think affects this. – TnF Jan 16 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.