1

Recently I've been having trouble playing video in Firefox reliably.

Often the same video that played a moment ago, then won't play after navigating away and back.

This is what I see instead:

Your browser does not currently recognize any of the video formats available.

When I follow the link...

Click here to visit our frequently asked questions about HTML5 video.

It shows that HTML5 video is supported by my browser:

What does this browser support?

It is annotated with an asterisk that H.264 playback depends on hardware and operating system support. I have trouble believing that my OS (macOS 10.12.6) or my hardware (a fairly recent MacBook Pro) is incapable of playing H.264 video... especially since I watched YouTube videos on it, in Firefox, for a long time prior to this without any problems. I keep Firefox up to date (currently v64.0). And the wording "depends on hardware and operating system support" is pretty vague, leaving me wondering where to look next to troubleshoot this.

I did find a similar question on Stack Exchange, but the accepted answer is not applicable to me because in about:config I do not have the entries rsa_rc4_128_sha/rsa_rc4_128_md5 mentioned in that answer. My issue may still be related to SSL in a different way, but I am left guessing at this point.

Any suggestions would be appreciated.

1

A few users have had similiar problems that were resolved on the Mozilla forums that might help.

https://support.mozilla.org/en-US/questions/1177497

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions that Firefox installs on its own are hidden from this page, so everything listed here is your choice (and your responsibility) to manage.

Try looking at the extensions for your browser and see if there is still a YouTube™ Flash® Player (or something similiar) extension on there. If so, try removing it and see if that fixes the problem.

  • Thank you for the suggestion. While I don't have YouTube™ Flash® Player installed, I did have an add-on called Disable Autoplay for YouTube™ enabled. I have disabled it and re-launched Firefox. This seems to have helped, but I will wait and see before jumping to conclusions. – Mentalist Jan 16 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.