After years struggling with safely removing USB external hard drives, and getting the famous "Windows can't stop your device because a program is still using it. Close any programs that might be using the device, and then try again later", I've finally found out what was holding it.

I've read issues and tried every possible solution suggested all over superuser and the web, nothing worked. (such as all answers in this: How to safely remove a USB drive when "Windows can't stop your 'Generic volume' device because a program is still using it."?)

  • 1
    Is there a question here? I see you state that you had a problem and that "I've finally found out what was holding it", which seems to say that you have a solution to your problem - but I don't see a question.
    – Mawg
    Commented Jan 17, 2019 at 7:50
  • 2
    @Mawg My intention was to share the knowledge so others don't suffer as much as I did. Not sure if I made it the right way though, happy to hear suggestions to improve Commented Jan 18, 2019 at 2:47
  • 1
    Sorry, I hadn't noticed that it was you who answered. Yes, asking and answering a question in order to help others is acceptable. In fact it is encouraged for canonical questions like this. Don't forget to accept your answer :-)
    – Mawg
    Commented Jan 18, 2019 at 7:29
  • 2
    Does this answer your question? Can Windows tell me what is using my USB drive?
    – root
    Commented May 4 at 8:05

2 Answers 2


If nothing else works, try checking if Task Manager is open, and closing it.

So finally today I've found out, thanks to this post in another forum:

It was Task Manager! (which I always keep open to observe CPU usage)

Also found out that Event Viewer can be of help to get more specific information at what's keeping safe remove from working. Got it from this superuser post, which informs that in event viewer, System, there's a message information the program that prevents the remove from happening:

The application \Device\HarddiskVolume5\Windows\System32\Taskmgr.exe with process id 3708 stopped the removal or ejection for the device USB\VID_0480&PID_A00C\20150207045837.

  • It's so crazy how Windows doesn't give any information in cases like these. Thank you.
    – 1j01
    Commented Apr 14 at 5:58

Restarting Windows Explorer from task manager solved the problem for me. Maybe that's overkill if simply close task manager releases the drive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .