2

Like many laptops, my HP Elitebook 840 G3 laptop has an embedded numeric keypad, which can be accessed using the fn modifier key. So, when I press fn + k it actually outputs "2" instead of "k".

Problem: Since a couple of days however, it doesn't output the numbers anymore. Instead they rather acts as navigation keys (arrow left, right, up, down, ...). Turning on "num lock" using the embedded numlk key (i.e. pressing fn+f12) permanently turns on the embedded numeric keys (as mentioned in the user manual), but this is not what I want either.

Question: How can I make the embedded numeric keypad output numbers again when using the fn modifier key? I am running Windows 10.

Elitebook keyboard from user manual

1

(Since I bumped into this issue for the 2nd time and it took me again a long time to figure out the solution, posting the answer to superuser)

Short answer

Turn on the NumLock feature using the Windows on-screen keyboard, rather than using the numlk key on the physical laptop keyboard.

Detailed answer

  1. Turn on the on-screen keyboard of Windows 10 (type flag key and then `on-screen') Start - on-screen result
  2. In the on-screen keyboard, click the Options key Options key
  3. In the dialog box that appears, select "Turn on numeric keypad" and click OK Dialog box
  4. Then, on the on-screen keyboard, click the NumLock key, to turn on the "num lock" feature. As a result, the LED of the numlk on the laptop's physical keyboard will be on. On-screen NumLock key
  5. Close the on-screen keyboard.

While this will turn on the LED of the numlk on the laptop's keyboard - just like it would when you would have turned it on by physically pressing fn+numlk - the effect is different! Now the embedded numeric keys are not permanently on, but only when you use the fn modifier key.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.