1

I have 2 Xbox Wireless gamepads, which I use with USB cables (I don't have the receivers at the moment). Everything was working fine until now. Didn't use them for a few weeks and now the PC just does not react in any manner to connecting them.

The only thing that happens is a controller vibrates when connected, but even the white lamp in the middle does not light up at all. There is no device connected/disconnected sound when I plug any of them in any port (I have tried all USB ports on the PC and external USB hub) and I could not find them being detected as anything in the device manager either.

Struggling for a couple days now -- I don't even have an entry point to fix the problem since the system just ignores the existence of the controllers. Other USB devices don't seem to cause any trouble on this PC and the controllers work well on another PC.

  • It can be many reasons. First troubleshoot hardware. Have you try another usb port? Is your Xbox controller can be user in another PC? Troubleshoot in Software. Is it something wrong with the game? Have you reinstall your xbox drivers? – Peter.G Jan 18 at 9:47
  • @Peter.G The controllers work well on another PC. I've tried all USB ports. No software sees the controllers since even the Device Manager does not react AT ALL to them -- neither of the controllers show up, even as something like "USB Device" with exclamation sign -- there is NOTHING happening except the controller vibration when I connect it. All other USB devices seem to work nominally. – Cos_ma Jan 18 at 12:34
  • You should edit your question to include all vital information (like you tried all USB ports) – Ramhound Jan 18 at 12:40
  • It is actually there, but sure, I will make it more clear. – Cos_ma Jan 19 at 4:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.