0

I am trying to set up an OpenVPN server on a computer running Ubuntu Server 16.04 that I have at work. I mainly followed this tutorial to set it up.

Unfortunately, when the clients try to connect (from somewhere outside the local network, so no loop) I get this error:

Thu Jan 17 12:21:49 2019 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)

Thu Jan 17 12:21:49 2019 TLS Error: TLS handshake failed

To determine if the issue was port-forwarding, I tried to connect to the server locally by changing the line in the config file from

remote [server's public IP] 1194

to

remote [server's local IP] 1194

After that the clients can connect successfully. So what I'm concluding is that the issue really is port-forwarding.

Here is a little map of my network:

Network Map

As you can see I have both the Server and the other computers connected to a D-link router, which is in turn connected to the ISP box.

I've tried to configure port forwarding on both modem configuration pages but to no avail.

Here's the D-link router configuration page:

D-link router config page

And here's the ISP box configuration page (it's in french, if you need translation for something don't hesitate):

ISP box config page

So that's where I'm stuck. Can you see any solution how I cann fix this ?

  • Anyone ? I'm really stuck here... – Samy Jan 29 at 20:16

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.