30

I followed a lot of different tutorials to install Android_x86 on VirtualBox (actually I want to install Android on a virtual machine, so if you have alternatives, I'm interested), I followed its step by step, but when the installation is completed : the GUI won't start... I just get this: boot

I find a solution here to edit the GRUB boot parameters. But the config I have doesn't match with theirs...

Here I have to change androidboot.hardware=android_x86 to androidboot.hardware=x86 but on my config I have androidboot.selinux=permissive

The ISO I downloaded is android-x86_64-8.1-r1.iso from here and the version of VirtualBox is 6.0.2 r128162 (Qt5.6.3)

If anybody can help me, thank in advance ! :D

2
  • I'm trying to run Android x86 in VMWare, with the same issue. Boots to console, no idea how to start the android UI! – Kristopher Noronha Dec 22 '20 at 15:52
  • 1
    See this post. – valentindusollier Dec 23 '20 at 16:57
32

Settings -> Display -> graphic controller set to -> VBoxVGA. Turn off Enable 3D Acceleration. This worked for me in my VM.

2
  • didn't work for me with Android-x86 6.0 Marshmallow (R3) – user3121518 Jul 28 '20 at 5:14
  • 3
    This worked with Android 9 (k49) and VirtualBox 6.1.10 on Ubuntu 20.04. The 3D Acceleration checkbox is off by default. All I had to do is go into the machine settings under the display tab and set the graphics controller to "VBoxVGA". – joe Aug 14 '20 at 8:19
26

I managed to solved my problem :

I just changed the display option Graphics Controller to VBoxVGA and enabled 3D Acceleration.

10
  • This does the job! But FYI, your second recommendation of 3d animation is the official recommendation anyway. I wish their manual will be updated with your first recommendation though! – LWC Mar 23 '19 at 21:46
  • Thanks for sharing the tweaks to do with VirtualBox. It works smoothly now. – bsound Jul 3 '19 at 3:41
  • 4
    That, however, would seem to be a problem in the future, as VBoxVGA is deprecated. VBoxSVGA appears to work. – Auspex Nov 6 '19 at 11:54
  • 5
    Isn't "3D animation" supposed to be "3D Acceleration"? – Maxim Mazurok Nov 21 '19 at 18:57
  • 4
    Won't work, you can't use 3d acceleration with VBoxVGA – unixandria Mar 23 '20 at 14:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.