Windows 10 Pro, latest build. Office 2016. Fully patched. Exchange Server 2016.

I'm a network administrator at a public library. We have several PCs that are logged in with a generic/shared account, because we have staff coming and going from those areas all day long that need to be able to quickly check email and search the catalog without having to log in and log out every time.

In the past, everyone sets up separate profiles in Outlook, but does NOT check the box that says "remember my password". They sit down, open Outlook, pick their name from the drop down list of profiles, and it asks for their password. Then they just close Outlook when they're done, all good to go.

This has worked beautifully for years.

On this one PC, just one PC, it suddenly stopped working a few months ago. It's now remembering everyone's passwords, even though they are not checking the "remember my password" box.

What I've done:

  • Verified in their account settings that it's set not to remember passwords.
  • Removed all Outlook profiles, forcing the users to recreate them.
  • Removed all entries from the Credentials Manager, but it just keeps putting them back in.
  • I've even disabled the Credentials Manager service, and it still remembers passwords while disabled. When I re-enable the service and go into the Credentials Manager, all of their entries are there, and I have to manually remove them.
  • Verified that there isn't a GPO causing problems here.
  • Nuked it, reinstalled Windows completely, it worked fine for a few weeks, then started doing it again.
  • Swore at it, took it out in the alley and smacked it around a little bit, and threatened it's family. It's still not cooperating. I'm contemplating trying the opposite approach, maybe buying it some flowers and taking it out to dinner.
  • Is there any third-party add-in?We can try opening Outlook in safe mode to see if the issue continues. Exit Outlook, press Win key + R to open the Run command, type outlook.exe /safe and then press Enter. – Perry Jan 21 at 8:37

It turned out to be cached exchange mode. We normally do not turn it on. I don't know how it's getting enabled on this one particular PC, but not on any of the others. That's another mystery though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.