0

I am typing this on my phone now as my laptop has been put out of use by what had just occurred.

After a recent windows 10 update, I was once again faced with problems relating to my Ubuntu dual boot. This time however the situation seems different as my laptop did not boot directly into Windows, rather booted into a very stripped down version of grub 2, and upon exiting I was greeted with a system menu showing 2 'windows' options and an 'unknown device'. Windows was the only option that worked so I used Windows for the past few days. Recently windows has become very slow and sluggish hence I was trying to get my Ubuntu back.

As this is a problem I had not faced before, I tried to use a boot-repair USB drive this time, however I ran into many errors with this software. First it tells me:

$GPT detected. Please create a BIOS-Boot partition...$

Which I attempted by setting my UEFI partition to unformatted, however not only did that not work it seemed have resulted in my being unable to access even the stripped down grub menu to boot into Windows, instead displaying the error 'no boot able device'.

Next I tried to alter the settings of boot repair by changing in the settings, under >GRUB location, and ticking 'Separare /boot/efi partition:' as suggested by the error message. This still didn't seem to work and I was given the following pastebin:

http://paste.ubuntu.com/p/hTz4vjdpSD

At this point I'm quite afraid of doing much else now for fears of making my predicament even worse. That is why I have turned to the experts at SU wondering if anyone here could shed some insight into the issue at hand here.

Here is a boot repair summary generated by the app:

http://paste.ubuntu.com/p/PdNBXrX4mF/

Thank you very much!

  • Messing with the EFI partition has that obvious result. You need to learn how to work with UEFI if you want to dual-boot. Once you do that you will also understand that Windows feature updates do not disrupt the dual-boot; worse case scenario it change the boot order back to Windows - convenient because it takes several reboots to install those updates - but it can be easily changed back to "Ubuntu" (Grub) once done, at UEFI settings. – GabrielaGarcia Jan 18 at 21:59
  • @GabrielaGarcia haha I figured that was probably the cause of the problem. For my current situation, what would you recommend me doing? – CowNorris Jan 18 at 22:11
  • Booting Windows installation media in the recovery environment may be able to recover the Windows boot EFI files (and the partition itself). Then Boot-Repair may do the same for Ubuntu. – GabrielaGarcia Jan 18 at 22:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.