0

When I try installing gulp on my ubuntu server I always get these error. I don't know what's wrong? It happens in a new folder after a fresh npm init.

martin@serveralpha:/var/www/xyz$ npm install --save-dev gulp
npm WARN xyz@1.0.0 No description
npm WARN xyz@1.0.0 No repository field.

npm ERR! path /var/www/xyz/node_modules/.array-last.DELETE/node_modules/is-number
npm ERR! code ENOENT
npm ERR! errno -2
npm ERR! syscall rename
npm ERR! enoent ENOENT: no such file or directory, rename '/var/www/xyz/node_modules/.array-last.DELETE/node_modules/is-number' -> '/var/www/xyz/node_modules/array-last/node_modules/is-number'
npm ERR! enoent This is related to npm not being able to find a file.
npm ERR! enoent 

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/martin/.npm/_logs/2019-01-19T17_47_42_221Z-debug.log
  • The output starts with two warnings. Have you addressed those? – fixer1234 Jan 19 at 21:39
  • Yes, I have, but they are not the problem. Anyway, I have already solved my problem, or at least I know why it is not working. I tried installing gulp in a VMware shared folder on the guest machine. This does not work, but I don't know why. As a workaround, I installed it as host. – kitikonti Jan 20 at 22:24
  • Consider posting an answer to explain your solution. That will be helpful to others with the same problem. – fixer1234 Jan 20 at 22:27
1

The Problem, in this case, was that I tried to install gulp in a VMware shared folder, from the guest machine. I don't know why but this does not work. After I tried installing this from the host machine it works.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.