Things I've tried:

On Win 7 computer - it's a home network (not public), advanced sharing settings all set as permissively as possible, shared folders have the following groups set to "FULL CONTROL" for both sharing and security: everyone, network, guest, anonymous. Disabled IPv6. IPv4 is set to static IP. Left homegroup (since win 10 doesn't care about this anymore and it wasn't working with it on). Verified it's connected to the same 5G network as my Win10 computer. Both use wireless.

I found advice that seemed sensible to enable the "Function Discovery Resource Publication" so I set both machines to load the service automatically.

On win10, pinging the machine by name returns the right address. NSlookup returns an address on the Internet for some reason instead of the local machine (non-authoritive answer No idea why or how to fix it. If I look in the router settings, it shows the computer with the right name and IP in the list of connected devices.

EDIT: I almost forgot; if I type \IPADDRESS into Windows Explorer on Win10 where IPADDRESS is the ipv4 of the Win 7 machine, it gives me a username and password login (which it shouldn't do) and if I type "guest" with no password, it lets me connect.

Also, during all of my testing and changes, using VNC with just the hostname has worked flawlessly. Apparently my VNC client is able to get the right IP somehow.

  • Maybe this?....zdnet.com/article/… – Moab Jan 20 '19 at 0:04
  • You MUST use exactly the same username and password on both systems, or else create an account on the Win7 system and then enter that account name & password when you are prompted. And please turn off the Guest account(!), unless you want to invite exploits. – Debra Jan 22 '19 at 21:37
  • BTW, a quick method that usually is easier for me is to type the command "NET USE T: \\remotesysname\c$ /persistent:yes" where "remotesysname" is the name of the Win7 system, and T: is not necessarily the letter you must use for any reason. Again you have to have either the identical account created on that system, or else add the username & password to the "NET USE" command. ("NET USE /?" for help with this.) Then in the future you can always refer to T: instead of trying to browse & re-connect. – Debra Jan 22 '19 at 21:39

I'm not sure if you are still struggling with this issue, but:

This is probaly caused by update kb4480970 installed on the Windows 7 machine. You can resolve this issue by installing hotfix (KB4487345) which can be installed from here

This hotfix is not included in the regular Windows 7 updates.

(Thanks to Twisty impersonator who has adressed this solution here)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.