7

So I have a laptop with Intel HD Graphics 530 (integrated graphics), and I ran into a problem I hadn't run into before and I think the culprit is that the laptop is sending w.e. resolution my laptop thinks is the "best" and just scaling it to match what "I" want the resolution to be (I think this might be a feature update?). My laptop is connected via HDMI to a receiver, and the receiver is connected to a TV. I know my TV is NOT 4K capable, but my receiver is. When I connect the laptop it automatically sets the display resolution to 3840 x 2160... 4K. So it seems my laptop is detecting the receiver accepts 4k and it's sending 4k signal. But my TV does not, and so I just see a black screen (but sound works via the receiver). I tried to lower the resolution of the TV signal, but my laptop keeps insisting on sending 3820x2160 resolution by scaling w.e. it's displaying to what I want the signal to be (frustrating!). I've played with the aspect ratio settings to no success... how do I set my "Active signal resolution" manually?

I've attached a screenshot of what the display says under the windows "advanced display settings" information.

enter image description here

6

I had the same problem, and for me at least clicking on "Display adapter properties for Display 2" let me pick the right resolution. I went to Settings>System>Display>Advanced display settings>Display adapter properties for Display 2

(Settings as in the settings you get when you click the little gear icon in the start menu or start typing "Settings" in the start menu in windows 10).

Then, click "List All Models,"

... And my correct active signal resolution was listed, so I picked it and clicked OK. I hit "OK", then Apply, and this fixed it for me.

I have Windows 10 and a LG 29UM68 monitor, displaying only on the monitor.

1

The solution I followed is the one provided here: https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/incorrect-active-signal-resolution/9ff80937-8959-42bf-acc7-cca8a3bae441

Basically make sure that in the settings for the Intel graphics, the scaling is set to "Maintain Display Scaling." For some reason when I played with this setting it didn't work the first time, but I made sure I set the correct resolution and selected that "Maintain Display Scaling," and the "Active Signal Resolution" matched the "Desktop Resolution."

Edit: This solution worked when I had my laptop display and the external display active (either on duplicate or extend); it did not work when I set my external display as the only one active (here it doesn't matter I correct the resolution when in duplicate or extend, when I switch to external display only it appears the resolution goes to the 4K resolution and I can't change it since I can't see anything.)

0

Wasted a lot of time on this till I found a general solution that works with all GPUs:

  1. go to Advanced Display Settings -> Display adapter properties for display -> List All Modes
  2. Select any lower resolution (e.g. 1680 by 1050) and apply - the active signal resolution should have changed to 1920x1080 in the Advanced Display Settings window
  3. Now select the 1920x1080 resolution again and active signal resolution remains the same

This is a lot of steps to repeat if switching between multiple display configs is needed as in my case. Tried saving and restoring monitor profile using displayfusion, actual multiple monitors and monitor profile switcher but none would restore the active resolution. Only thing that worked was WsDisplaySettings :

save:

wsds.exe -save <profile_name>

load:

wsds.exe <profile_name>

Also has a tray app but I found it to interfere with displayfusion. The free version shows an annoying message box each time it is run but can be dismissed with an Enter.

0

Just putting it out here since I didn't exactly find this anywhere;

I have a 2-display setup. One 24 inch 1080p monitor and a 50 inch 4K-TV.

Both resolutions are set to 1080p. For my 4K-TV the active signal resolution was 3840x2160 instead of 1080p UNTIL I changed the setting in the Intel Graphics Command center (I think AMD/Nvidia have similiar settings) for the TV from 'Maintain Display Scaling' to 'Maintain Aspect Ratio'.

After I did this both resolution and active signal were 1920x1080.

-1

As others have noted, this seems to be related to a recent update to Windows 10 that, in some cases, conflicts with the drivers.

Here's what worked for me: 1. In Settings - Apps - Apps & Features, uninstall "Intel Display Adapter" 2. In Device Manager, update the driver for the video adapter. 3. Then follow the instructions that Abhineet Singh posted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.