0

I'm running Windows 10 with Cygwin. When opening Cygwin from the start menu (Pointing to C:\cygwin64\bin\mintty.exe -i /Cygwin-Terminal.ico - and then entering "exit", the process gets unresponsive and I have to kill it from the task manager.

I tried the following:

  1. Open a cmd (not elevated) and then enter the command as it appears in the shortcut. It does not start in my home folder (C:\cygwin64\home\david) but it exits gracefully.
  2. Changing the shortcut to run as administrator - Cygwin quits gracefully but it's a hassle to approve the program to run as administrator.

Any more ideas?

Thanks!

  • Any program that could potentially interference with cygwin ? cygwin.com/faq/faq.html#faq.using.bloda – matzeri Jan 20 at 17:05
  • Try to run mintty as an administrator. – harrymc Jan 20 at 21:13
  • Hi @harrymc , I wrote in my question that running the app as administrator solves the issue but it's a hassle. – David Kon Jan 22 at 8:23
  • @matzeri - You are right - I have one of the apps listed in the page, disabling it solves the issue. Can you post it as the answer? – David Kon Jan 22 at 8:25
  • I have noticed that it happens on my laptop; although initially I thought it was SSD/HDD issue – Kunal B. Mar 29 at 19:51
0

Malfunction of cygwin programs is usually caused by third part programs. Most Antivirus or unusual behaving drivers

A not exaushing list is available at
https://cygwin.com/faq/faq.html#faq.using.bloda

If you have some of them you can try disabling or removing those.

0

I have searched for this hanging issue for along time. The way I overcame this is by creating a new shortcut with target as "%windir%\system32\cmd.exe " /c C:\cygwin64\bin\mintty.exe -i /Cygwin-Terminal.ico - This seems to have solved my issue for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.