6

I installed XML Tools 2.4.11 using Plugin Manager, however the only thing showing up in menu is How to install item and clicking on it I get a message:

Unable to load libXML and/or libXSLT.

Please install external DLLs into NPP root directory (same directory than Notepad++.exe) or in "%appdata%\Notepad++" folder and restart NPP.

These libraries are available in the subfolder "ext_libs" of xmltools zip archive.

If I look into my Notepad++ folder, I can clearly see there's both libxml2-2.dll and libxslt-1.dll. I tried replacing them with an older version bundled with XML Tools from 2016, but I'm getting the same error.

I have 32-bit version of Notepad++ on 64-bit Windows. Here's my debug info:

Notepad++ v7.5.9   (32-bit)
Build time : Oct 14 2018 - 15:02:52
Path : C:\Program Files(x86)\Notepad++\notepad++.exe
Admin mode : OFF
Local Conf mode : OFF
OS : Windows 10 (64-bit)
Plugins : NppExport.dll DSpellCheck.dll mimeTools.dll NppConverter.dll NppTextFX.dll NppXmlTreeviewPlugin.dll PluginManager.dll Tidy2.dll XMLTools.dll

Not sure what to do here to make this work.

  • The answers here and here might fix the problem (presumably they have helped some people as they are upvoted, but I tried all this and it still didn't work). – Brian Hooper Jan 22 at 16:14
2

I tried some of the answers that Mr. Hooper linked, and also did not have success. After a whole lot of see-if-this-fix-works, I ended up completely uninstalling without saving any settings, grabbed the absolute latest installer (7.6.2 - 32bit), and installed it. Then, using the built-in Plugins Admin, I installed XML Tools, and it worked!

It should be noted that Notepad++ 7.5.8 (32 bit) with XML Tools 2.4.9 (manually installed) DID work as well. I still don't have an answer as to what's causing the problem, which is the frustrating part, but I THINK it might have something to do with an update process vs. uninstall and reinstall.

  • 1
    Well that fixed it. I guess there was something off with my installation. I don't know why I had 32-bit version to begin with. I also didn't have Plugins Admin, I had to manually install Plugin Manager. Installed Notepad++ with default settings and everything magically works. – lovrodoe Jan 23 at 8:05
1

Try with new default plugin manager

I still had the OLD plugin manager inside NPPx86.

A while back there was a bit of drama in the NPP project and the old plugin manager got kicked out of NPP in version 7.5 on 2017-08-16. (Archived here.)

So, back then, if you wanted to have any plugin manager at all then you had to manually insert the old plugin manager into NPP yourself. And that's what I did.

But now NPP seems to bring its own NEW plugin manager.

So I uninstalled NPP, deleted %ProgramFiles(x86)%\Notepad++ and deleted %appdata%\Notepad++. And then did a reinstall using "Notepad++ Installer 32-bit x86" (npp.7.6.6.Installer.exe).

Then via Plugins | Plugins Admin...
Plugins | Plugins Admin

I was successfully able to install XML Tools. Plugins Admin window with XML Tools

So fresh install did the trick for me. (But if you're hesitant you might first try to throw out the old plugin manager manually somehow before you reinstall.)

  • Thanks! This worked for me too (7.6.6 32-bit). What were you going to write after "Here's a little background for the"? Left everyone hanging! – Jay Cummins Apr 9 at 17:14
  • @jay: Oh right. Sorry. I first wanted to add the link to the drama there. But then i just made it an inline link instead. :) – StackzOfZtuff Apr 9 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.