0

I have recently changed my ISP, and they installed a new router which is a DLINK DIR 600M. Since then, I was unable to access the server running on my laptop (webpack dev server) from my mobile phone which are both connected to the same WiFi.

I had this in my router right now:

client table

The server is running on my laptop, and I can access it using 192.168.0.4:8081 from Chrome's address bar. I can call the APIs from it and am getting the responses. However, when I tried to run the same in Android (a hybrid app running in a webview) I get this error:

error on Android

It is saying that the address is unreachable. I think it has something to do with my router, as this app works fine in office WiFi and only not in home.

What is the setting that I had to do on my router to enable this functionality?

1

Looks like your router has the function "Wireless Isolation" (often called "AP Isolation") enabled.

This prevents clients connected to the WiFi network to communicate with each other (and really, to any other hosts in the network, they can just access the public Internet via the router), even if they're on the same network!

Looks like, on your router, the option is under "Wireless Basics":

DLink Wireless Isolation

  • Thanks for the answer. I had it disabled. If I enable it, I'm getting a ERR_CONNECTION_ABORTED instead. – Sri Harsha Chilakapati Jan 21 at 10:58
  • Don't know why but toggling it and rebooting the router twice made it working! – Sri Harsha Chilakapati Jan 21 at 11:16

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.