0

I install latest version as official help said in this link. I try install this bundle on windows 10. Installing step was successful but when I want run that, I get following error.

I try install this version from this link. I'm using Windows 10 x64. I Checked the system %PATH% environment,too, but it is correct as official help said.

C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require': cannot load such file -- rex/post/meterpreter/packet (LoadError)
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require_with_backports'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `block in require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:240:in `load_dependency'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `require'
    from C:/metasploit-framework/embedded/framework/lib/rex/post/meterpreter/extensions/stdapi/railgun/tlv.rb:26:in `<top (required)>'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require_with_backports'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `block in require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:240:in `load_dependency'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `require'
    from C:/metasploit-framework/embedded/framework/lib/rex/post/meterpreter/extensions/stdapi/railgun/railgun.rb:41:in `<top (required)>'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require_with_backports'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `block in require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:240:in `load_dependency'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `require'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/post/windows/railgun.rb:2:in `<top (required)>'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require_with_backports'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `block in require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:240:in `load_dependency'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `require'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/post/windows.rb:13:in `<module:Windows>'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/post/windows.rb:3:in `<top (required)>'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require_with_backports'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `block in require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:240:in `load_dependency'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `require'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/post.rb:18:in `<class:Post>'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/post.rb:6:in `<top (required)>'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require_with_backports'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `block in require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:240:in `load_dependency'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `require'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/exploit.rb:32:in `<class:Exploit>'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/exploit.rb:30:in `<module:Msf>'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/exploit.rb:5:in `<top (required)>'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require_with_backports'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `block in require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:240:in `load_dependency'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `require'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/auxiliary/mqtt.rb:3:in `<top (required)>'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require_with_backports'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `block in require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:240:in `load_dependency'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `require'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/auxiliary/mixins.rb:27:in `<top (required)>'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require_with_backports'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `block in require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:240:in `load_dependency'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `require'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/auxiliary.rb:16:in `<class:Auxiliary>'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/auxiliary.rb:14:in `<module:Msf>'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/auxiliary.rb:4:in `<top (required)>'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/backports-3.11.4/lib/backports/std_lib.rb:9:in `require_with_backports'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `block in require'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:240:in `load_dependency'
    from C:/metasploit-framework/embedded/lib/ruby/gems/2.4.0/gems/activesupport-4.2.11/lib/active_support/dependencies.rb:274:in `require'
    from C:/metasploit-framework/embedded/framework/lib/msf/core.rb:66:in `<top (required)>'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/payload/apk.rb:3:in `require'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/payload/apk.rb:3:in `<top (required)>'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/payload_generator.rb:2:in `require'
    from C:/metasploit-framework/embedded/framework/lib/msf/core/payload_generator.rb:2:in `<top (required)>'
    from C:/metasploit-framework/bin/../embedded/framework/msfconsole:48:in `require'
    from C:/metasploit-framework/bin/../embedded/framework/msfconsole:48:in `<main>'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.