I ride the train every weekday morning, and I like to work done on the train. I require the internet, and luckily the train (Utah Transit Authority Frontrunner) provides free WiFi for passengers.

I have a computer dual booting Windows 10 and Xubuntu 16.04. On Windows I can connect to the WiFi and I get a notification saying that additional authentication is needed. When I click the notification a new window opens in my default browser asking me to agree to terms and conditions. I do so and I'm able to access the wifi.

Linux connects to the network, but never gets a notification for additional authentication. I am connected, but when I open my browser I am unable to connect to the internet because the terms and conditions window never opens.

My default browser in my Windows Install works fine with Edge and Chrome as the default browser.

On Xubuntu I have set the default browser to Chrome and Firefox. Neither will ever access the terms and conditions page.

How can I get this authentication page to appear on my Xubuntu install?

  • What does chrome or firefox say when you try connecting to any website? Does linux successfully get an ip address / subnet / route / DNS? You can connect to other wifi networks/routers successfully in linux?
    – Xen2050
    Jan 23, 2019 at 4:27
  • I get the generic "unable to connect to the internet" message on each respective browser. I am able to connect to a number of other networks, even many that require an authentication step. How can I check to see if it gets an ip/subnet/etc? Would the "ip" command give that information? Jan 23, 2019 at 23:36
  • I haven't used a terminal command to check recently, just a gui like Network Manager applet or wicd's, they should have a "Connection information" or similar entry in a right or left click menu. Possibly unrelated, but if your wifi adapter is very old (only B/G?) I've noticed that some free wifi with captive portals in places like McDonalds won't connect to old devices anymore
    – Xen2050
    Jan 24, 2019 at 0:43
  • So I checked and I do get an IP when I view the connection. It was something with the captive portal as @QuickishFM said. Got it working with his answer. Jan 30, 2019 at 18:04

1 Answer 1


You need to access the captive portal. Try to navigate to captive.apple.com (A generic captive portal used in Apple devices which usually redirects - just something to try first), something like Google or Yahoo, and if not, then the Utah trains website . This should ask it to go to the captive portal and then to the webpage you need.

Also check you are connected properly, and Windows isn't automatically applying any proxies for you. If it is, then try and apply these to the Linux install too.

  • This worked perfectly. Is there any way to make this process automatic? Jan 30, 2019 at 18:02
  • I'm glad you figured it out - perhaps simply visiting a captive portal page would work? I also think you could make a cron job to ping Google when there's a valid IP (or something like curl your own IP, anything that checks internet connectivity). If there's an error returned (meaning no internet), then it would automatically launch firefox to go to captive.apple.com or something. This is a very basic idea and is the first idea I thought of, so it might not work out of the box but you should apply the solution that worked for you into an automated method.
    – QuickishFM
    Jan 30, 2019 at 18:12
  • 1
    Thanks Quickish. I'll see if I can get that to work. In any case, thanks for the answer. Feb 4, 2019 at 18:26
  • I can confirm that this works at Boston Logan airport as well.
    – Taegost
    Mar 31, 2019 at 17:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .