I creating new question for clarification since I can't comment on existing questions due to 50 reps required. The following two questions mention mRemoteNG automatically scales/zoom RDP connections. But I have trouble implementing this solution.

Remote Desktop: Zoom AND full screen -- how? (Win10 remote, Win7, 2008 & 2003 hosts)

Can I scale (stretch) a Remote Desktop session locally?

  1. I have set Resolution to 1280x1024 and hoping it will scale to fill the blank gray area or full screen.
  2. I have tried the Smart Sizing on and off, plus the Fullscreen mode without luck
  3. I would prefer to get mRemoteNG working. I have tried various other applicable solutions from the above two answers without much success.
  4. What is exact setting needed to trigger mRemoteNG to upscale the RDP session?

Screen Shot of mRemoteNG

1 Answer 1


There's a GitHub issue about this, and a comment in that thread has a workaround for the issue:

A workaround for this issue on Windows 10: Find mRemoteNG.exe file, open "Properties" -> "Compatibility" -> "Change high DPI settings" -> "High DPI scaling override", turn on "Override high DPI scaling behavior" option and set "Scaling performed by:" to "System" or "System (Enhanced)", not "Application".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .