0

When viewing source code on GitHub, their CSS specifies the following fonts:

font-family: SFMono-Regular,Consolas,Liberation Mono,Menlo,Courier,monospace;

Even though I have SFMono-Regular installed on my Mac (in ~/Library/Fonts/SFMono-Regular.otf), Firefox uses Menlo to render the element. Both Safari and Chrome correctly use SFMono.

How can I get Firefox to detect and use the fonts installed in ~/Library/Fonts?

0

From Mozilla Support

This can happen when Firefox has a problem to access locally installed fonts because of sandbox security issues.

https://wiki.mozilla.org/Security/Sandbox 

You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting.

security.sandbox.content.level = 1
close and restart Firefox to make the change effective. 

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

http://kb.mozillazine.org/about:config 

If you also have this problem on the about:config page then try to boot the computer in Safe Mode.

  • This didn't work. Even after disabling the sandbox entirely, Firefox still uses Menlo – 130e13a Jan 25 at 9:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.