4

I've just got a second graphics-card and I wanted to try SLI. After I've installed the latest driver for my cards (bother are the exact same model and chip), I was able enable SLI in the Nvidia Control Panel.

Somehow my system is not happy at all with those cards.

I'm getting hard lags in normal operating mode. Windows lags hard, I cannot move or some windows, even the sound is laggy (when running music sometimes there is no sound for 1-2 sec).

I've read, that RAM has to be SLI-Certified and that CPU might be the issue.

How would I track down the source of the problem ?

My current setup:

If any other detail is needed I will add them ! (just let me know in the comments).

Things I've tried so far:

  • disabling HPET (did not work, does not seem to be active)

enter image description here

  • 1
    1. I assume you've mixed around the PCIe slots and tried various combinations but it seems that you want to use the two light brown colored slots for the GPU cards. 2. Ensure both cards get full and total power to all available power terminals for both cards 3. Ensure the latest firmware is installed on the motherboard BIOS and you are using the latest drivers at the OS level for the GPUs. 4. Not sure if it's applicable, but check BIOS/UEFI and see if you can disable all internal video output for built in output video ports and test if that helps. Quick ideas only. – Pimp Juice IT Feb 3 at 15:14
  • 1
    Questions: (1) Are you using a two-pronged bridge? (2) Are the GTX cards in PCIe1 and PCIe3? (3) Do you have one or more monitors? (4) Does the NVIDIA Control Panel has in the 3D Settings tree "Configure SLI, Surround, Physx" and is the "Maximize 3D Performance" option set? (5) If you click any link in the "3D Settings" tree and at the top in "3D Settings" see if "Show SLI Visual Indicators" is checked. Post a screenshot of the white vertical bars on the left-hand side of the screen with a green box in the middle. – harrymc Feb 3 at 21:35
  • 1
    It is my understanding that GTX960's cannot be used in SLI, due to driver lockdown, there are ways to modify the .sys file prevents the lockout though. Just to confirm that isn't the case here, do you actually have SLI enabled, within the Nvidia Control Panel? – Ramhound Feb 4 at 8:40
  • @Ramhound I was able to enable it. I've turned it back off since I could not operate to the reasons mentioned above. The SLI itself kinda worked. - I will post some updates later when I get home including some images ! – Felix D. Feb 4 at 8:47
  • @Ramhound: SLI works on it. See NVIDIA GeForce GTX 960 SLI Review where it says "performance upscale in excess of 80 percent in games that take advantage of SLI". – harrymc Feb 4 at 10:17
3
+50

The facts here are as follows:

  • SLI is successfully marked as enabled in the Nvidia Control Panel,
  • Video performance is bad.

If we couple these facts with the Nvidia article of Introduction to SLI Technology which says:

Although the bridge is not explicitly required to enable 2-way SLI with most GPUs, it provides a dedicated communication pathway for the GPUs to exchange data across. When this link is not present the PCIe bus will become the means of communication, which can degrade performance.

And then add the evidence that shows that SLI is very effective for your video card, in the TechPowerup article NVIDIA GeForce GTX 960 SLI Review that says this:

All by itself, the GTX 960 SLI is a cracker of a combination, and we see performance upscale in excess of 80 percent in games that take advantage of SLI, at 1080p and 1440p resolutions.

If we take all these facts in consideration, the natural conclusion is that for some reason your SLI bridge is not functioning. The two video cards have probably established SLI across the PCIe bus, with resulting poor performance, as described in the documentation.

It is impossible to analyze a physical problem causing the non-functioning of the SLI bridge without physical access to the computer.

A software problem can only be in the driver. Try in the page of NVIDIA Driver Downloads to use the option of "Automatically find drivers for my NVIDIA products", so as to let NVIDIA analyze your hardware and suggest the right driver. Verify that it's exactly the one that you are already using.

  • I've testet with a new bridge and it's not working without any lags. FPS are still a little low but at least I can use the system now with both cards active ! thanks alot for your help and time ! – Felix D. Feb 11 at 7:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.