0

I have a development HW with linux running and only root user. Upong bootup it asks me only username (which is root) and no password. So I assume there is no password for root user. Now I want to transfer a file from host system (Ubuntu 16.04) to this HW using scp but I keep getting asked for a password.

$ scp my_local_file root@192.168.292.123: /home/root

root@192.168.292.123's password:

Permission denied

When I leave it blank and press enter, it says permission denied. I even tried the password as root and still no luck. I am pretty sure it worked before but dont remember giving it any password. How to scp to this remote machine?

0

Most of the time ssh is set up not to allow empty password login and never to allow root to login with a password at al. You can check your configuration on the device or log onto it and scp from it to the host system. (Check sshd_config for PermitRootLogin and PermitEmptyPasswords settings.)

Your best bet is probably to put a keyfile on the device and have an easier and more secure future. :)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.