1

I am using the following hardware:

pfSense with 2 ports
TP-Link TL-SG801E switch with 8 ports
TP-Link TL-MR3420 with OpenWRT

My main idea is to create a guest wifi network with captive portal which is managed and issued by pfsense. Currently my setup is setting the wifi router into AP mode and let pfSense do all the work.

I tried to create a new SSID, a VLAN interface and tie it together on the OpenWRT router. (VLAN 20) I have created VLAN 20 with a subnet of 192.169.20.1/24 on pfSense and configured DHCP for the VLAN 20 interface.

However, when I connect to the guest SSID, I am not getting an IP address. I suspect that I had to do some configuration at my switch but I can't figure it out as I thought VLAN tags are supposed to just travel through the switch.

Here is a diagram of my setup. (Currently there is only one port going to and from pfSense and OpenWRT router:

https://i.stack.imgur.com/4YgCu.png

Here are the additional screenshots for all the settings I've made for reference:

https://imgur.com/a/iixX1PA

0

Figured it out.

All I had to do was assign eth0.20(WAN port) because that is what I was using, not LAN. On the switch, I just leave the PVID setting as default and set the 802.1Q VLAN setting and tag port 1 and port 2 with VLAN ID 20.

All the ports that the VLAN is going through had to be tagged on all devices for it to work.

My setup is combining untagged packets and tagged packets. If you have other VLAN id, just tag them appropriately along with the original tagging. This will ensure that the ports will carry all the VLAN ID for packets that are going through it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.