1

I am trying to run a program, but I am struggling with getting getting the program to run because it requires OpenGL 2.0, and I have OpenGL 1.1.0. Is there any fix to this problem? I have updated windows and there is still no change.

This is the error I get:

Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior 2, swapinterval 1., profile 0) .
This is most likely caused by not having the necessary graphics drivers installed.
Install a driver providing OpenGL 2.0 or higher, or, if this is not possible, make sure the ANGLE Open GL ES 2.0 emulation libraries (libEGL.dll, IibGLESv2.dll and d3dcompiler_*.d11) are available in the application executable's directory or in a location listed in PATH.

Screenshot

3
  • Your only solution would probably be upgrading to OpenGL 2.0. – zx485 Jan 27 '19 at 22:38
  • @zx485, Well in my case, OpenGL is not upgradeable just like THAT. I need to update the drivers to SUPPORT OpenGL 2.0.VirtualBox, however, does not have those drivers. I need an answer for how I can solve my problem. – ProPane865 Jan 27 '19 at 22:41
  • Use a version of VirtualBox before OpenGL 2.0 support was disabled. or a different hypervisor entirely. Unless you implement the patch yourself what you want isn’t possible with any recent version of VirtualBox. – Ramhound Jan 28 '19 at 0:32
1

I have ran into the same issue and found that OpenGL 2.0 and higher is a bit broken in VirtualBox 5.x and, as far as I know, still not fully fixed.
With the GuestOS being Win7 or earlier it can be made to work by installing the guest drivers in safe-mode. For Windows 8 and later it will not work whatsoever.
There is an extensive thread on the matter on the VirtualBox forums. (If the link should become broken Google for "Virtualbox opengl 2". Should be one of the first hits.)
With that info and some experimentation I was able to get OpenGl (2 and 3) working in a Windows 7 guest. (I can't recall exact details. It was over a year ago that I last played with this. But that forum-thread should give you all you need.)

I don't know if the problem has been solved with the current VirtualBox 6.x series. I haven't had an opportunity to try that yet.

4
  • I do indeed have windows 7 installed as my guest, and I tried installing my drivers in safe mode. This however, still did not work. I also have looked at that thread before, however it did not solve my problem. Can you help me with the error described in the image link that I posted above? – ProPane865 Jan 27 '19 at 23:50
  • I will try updating Virtualbox to see if the problem is fixed – ProPane865 Jan 27 '19 at 23:54
  • I can also try downgrading if you would tell me on what version you got it to work. – ProPane865 Jan 28 '19 at 0:03
  • Virtualbox 6.0 did not fix the issue – ProPane865 Jan 28 '19 at 0:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.