2

When attempting

brew install --HEAD valgrind

I get this error:

==> Deleted Formulae apache-arrow cputhrottle liblastfm ruby@1.8 apache-arrow-glib hyper percona-server@5.6

valgrind: This formula either does not compile or function as expected on macOS versions newer than High Sierra due to an upstream incompatibility. Error: An unsatisfied requirement failed this build. Moes-MacBook-Pro:~ moesanjaq$ brew install --HEAD valgrind ==> Cloning https://sourceware.org/git/valgrind.git Updating /Users/moesanjaq/Library/Caches/Homebrew/valgrind--git fatal: dumb http transport does not support shallow capabilities Error: An exception occurred within a child process: DownloadError: Failed to download resource "valgrind" Failure while executing; git fetch origin --unshallow exited with 128. Here's the output: fatal: dumb http transport does not support shallow capabilities

When attempting

brew install valgrind

I get a much shorter error message

valgrind: This formula either does not compile or function as expected on macOS versions newer than High Sierra due to an upstream incompatibility. Error: An unsatisfied requirement failed this build.

I attempted following this article: https://www.gungorbudak.com/blog/2018/04/28/how-to-install-valgrind-on-macos-high-sierra/

After making the changes the head section of

 brew edit valgrind

looks like

head do

url "git://sourceware.org/git/valgrind.git"

depends_on "autoconf" => :build

depends_on "automake" => :build

depends_on "libtool" => :build  

end

Now when attempting

brew install --HEAD valgrind

I get to the build step and then this error:

=> Checking out branch master Already on 'master' Your branch is up to date with 'origin/master'. HEAD is now at e911f75 Fix callgrind_annotate Use of uninitialized value in numeric gt (>) ==> ./autogen.sh ==> ./configure --prefix=/usr/local/Cellar/valgrind/HEAD-e911f75 --enable-only64 Last 15 lines from /Users/moesanjaq/Library/Logs/Homebrew/valgrind/02.configure: checking for gcc-ar... no checking for perl... /usr/bin/perl checking for gdb... /no/gdb/was/found/at/configure/time checking dependency style of clang... none checking for diff -u... yes checking for clang option to accept ISO C99... none needed checking for a supported version of gcc... ok (Apple LLVM version 10.0.0) checking build system type... x86_64-pc-darwin checking host system type... x86_64-pc-darwin checking for a supported CPU... ok (x86_64) checking for a 64-bit only build... yes checking for a 32-bit only build... no checking for a supported OS... ok (darwin) checking for the kernel version... unsupported (18.2.0) configure: error: Valgrind works on Darwin 10.x, 11.x, 12.x, 13.x, 14.x, 15.x, 16.x and 17.x (Mac OS X 10.6/7/8/9/10/11 and macOS 10.12/13)

READ THIS: https://docs.brew.sh/Troubleshooting

When attempting

brew install valgrind

I get the same error as previous:

valgrind: This formula either does not compile or function as expected on macOS versions newer than High Sierra due to an upstream incompatibility. Error: An unsatisfied requirement failed this build.

Am I doomed to find my leaks manually when developing on Mac OS Mojave?

  • Valgrind says they have some upstream issue they can't fix right now – Ethan Z Feb 17 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.