1

When you drag the url bar from an internet explorer bar to a Windows folder, it creates a shortcut file. When double clicking that file, it should open that internet page in your default internet browser. This happens because by default, the filetype "url shortcut" is associated with your default browser in the registry.

I have here a file with a filetype of "url shortcut":

enter image description here

My issue is that when I double click a url shortcut filetype, instead of opening an internet browser page, it opens the print dialog:

enter image description here

Only if I DRAG the file onto an Internet browser page - will it open the linked shortcut in the browser.

I have tried to reset all file associations back to default but that didn't help. In my Windows 10, in the "Choose default apps by file type" I have "Internet Shortcut (.url)" SET to open with "Internet Browser" (with no option to choose the browser, even though CHROME is set as my default browser) but for some reason, instead of opening them in chrome, it opens the print dialog.

enter image description here

Can someone help with this?

UPDATE:

After playing around with registry keys, I was able to get Windows to ask me what program I wanted to always open this type of file with. If I choose "Internet Browser" it works once but if I double click it again, it will again start to open the print dialog.

But if I choose "Chrome" - it always opens in Chrome BUT only shows the shortcut link as text like so:

enter image description here

1

Have exactly the same issue. Appeared suddenly.

Solved it by deleting with tool RegEdit the "LegacyDisable" key in ...\IE.AssocFile.URL\Open

enter image description here

  • @Blackwood, I posted an answer. Can you upvote my Answer again? – Tom Mensink Apr 23 at 13:37
  • As you have edited your post to include an answer, I have deleted my comment. It wasn't me that downvoted your post. – Blackwood Apr 23 at 14:00
  • @Tom, I upvoted your answer only because I think that it's a valid suggestion, especially if it worked for you. But I can't mark it as solved as it didn't help me. I temporarily am using a chrome extension "URL Handler" which handles .url files if they open on in Chrome as plain text. – Zvi Twersky Apr 24 at 2:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.