4

I have reinstalled my system, and simply copied over my old home directory. However, I have also changed my user name.

When I attempt to create a new virtual machine, I'm presented with the error:

"Cannot create the machine folder test in the parent folder /home/alphacentauri/VirtualBox VMs. Please check that the parent really exists and that you have permissions to create the machine folder"

The problem here is that the path doesn't exist, my user name is not "alphacentauri" any longer.

But how would I fix this?

  • There doesn't seem to be any options within VirtualBox to specify the base path under which virtual disks should be made.

  • I already tried to update with a set -i oneliner everythin under ~/.config/VirtualBox however, this didn't seem to affect anything.

Interestingly, I can add existing virtual machines, as long as I manually edit the relevant files. However, these are machine specific files and don't appear to affect the global problem of creating a new virtual machine.

In short, it seems like there is some configuration file for VirtualBox which I cannot find, which allows it to remember what my old username was.

System: Debian 9.7 VirtualBox: 5.2.24 r128163 (Qt5.7.1)

2

To fix this you can follow this steps:

...change the default machine folder by selecting “Preferences” from the “File” menu in the VirtualBox main window. Then, in the window that pops up, click on the “General” tab. Alternatively, use VBoxManage setproperty machinefolder ...

From page 248 of the VirtualBox User Manual 5.2.24 VirtualBox User Manual 5.2.24

Hope this can help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.