2

Whenever I try to update my EC2 instance, I get the following error:

Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main                                                                                                                                                                                   | 2.1 kB  00:00:00
amzn-updates                                                                                                                                                                                | 2.5 kB  00:00:00
817 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package aws-cfn-bootstrap.noarch 0:1.4-30.21.amzn1 will be updated
---> Package aws-cfn-bootstrap.noarch 0:1.4-31.22.amzn1 will be an update
---> Package curl.x86_64 0:7.53.1-16.85.amzn1 will be updated
---> Package curl.x86_64 0:7.53.1-16.86.amzn1 will be an update
---> Package db4.x86_64 0:4.7.25-18.11.amzn1 will be obsoleted
--> Processing Dependency: libdb-4.7.so()(64bit) for package: rpm-libs-4.11.3-21.75.amzn1.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: cyrus-sasl-lib-2.1.23-13.16.amzn1.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: rpm-build-libs-4.11.3-21.75.amzn1.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: ruby20-libs-2.0.0.648-1.31.amzn1.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: iproute-4.4.0-3.23.amzn1.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: python27-libs-2.7.15-1.124.amzn1.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: pam-1.1.8-12.33.amzn1.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: httpd24-tools-2.4.37-1.83.amzn1.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: rpm-4.11.3-21.75.amzn1.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: pam_ccreds-10-4.9.amzn1.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: httpd24-2.4.37-1.83.amzn1.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: rpm-python27-4.11.3-21.75.amzn1.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: cyrus-sasl-2.1.23-13.16.amzn1.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: apr-util-1.5.4-6.18.amzn1.x86_64
--> Processing Dependency: libdb-4.7.so()(64bit) for package: sendmail-8.14.4-9.14.amzn1.x86_64
---> Package db4-utils.x86_64 0:4.7.25-18.11.amzn1 will be obsoleted
---> Package kernel.x86_64 0:4.14.94-73.73.amzn1 will be installed
---> Package kernel-tools.x86_64 0:4.14.88-72.73.amzn1 will be updated
---> Package kernel-tools.x86_64 0:4.14.94-73.73.amzn1 will be an update
---> Package krb5-libs.x86_64 0:1.15.1-19.43.amzn1 will be updated
---> Package krb5-libs.x86_64 0:1.15.1-34.44.amzn1 will be an update
---> Package libcurl.x86_64 0:7.53.1-16.85.amzn1 will be updated
---> Package libcurl.x86_64 0:7.53.1-16.86.amzn1 will be an update
---> Package libdb4.x86_64 0:4.8.30-13.el7 will be obsoleting
---> Package libdb4-utils.x86_64 0:4.8.30-13.el7 will be obsoleting
--> Processing Dependency: /usr/bin/db_stat for package: rpm-4.11.3-21.75.amzn1.x86_64
--> Processing Conflict: libdb4-4.8.30-13.el7.x86_64 conflicts filesystem < 3
--> Finished Dependency Resolution
Error: Package: rpm-build-libs-4.11.3-21.75.amzn1.x86_64 (installed)
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
Error: Package: rpm-4.11.3-21.75.amzn1.x86_64 (installed)                                                                                                                                                 [45/1125]
           Requires: /usr/bin/db_stat
           Removing: db4-utils-4.7.25-18.11.amzn1.x86_64 (installed)
               Not found
           Obsoleted By: libdb4-utils-4.8.30-13.el7.x86_64 (epel)
               Not found
Error: Package: pam-1.1.8-12.33.amzn1.x86_64 (installed)
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
Error: Package: rpm-4.11.3-21.75.amzn1.x86_64 (installed)
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
Error: libdb4 conflicts with filesystem-2.4.30-3.8.amzn1.x86_64
Error: Package: iproute-4.4.0-3.23.amzn1.x86_64 (installed)
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
Error: Package: httpd24-2.4.37-1.83.amzn1.x86_64 (@amzn-updates)
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
Error: Package: cyrus-sasl-lib-2.1.23-13.16.amzn1.x86_64 (installed)
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
Error: Package: python27-libs-2.7.15-1.124.amzn1.x86_64 (@amzn-updates)
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
Error: Package: sendmail-8.14.4-9.14.amzn1.x86_64 (installed)                                                                                                                                              [2/1125]
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
Error: Package: httpd24-tools-2.4.37-1.83.amzn1.x86_64 (@amzn-updates)
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
Error: Package: rpm-libs-4.11.3-21.75.amzn1.x86_64 (installed)
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
Error: Package: pam_ccreds-10-4.9.amzn1.x86_64 (installed)
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
Error: Package: ruby20-libs-2.0.0.648-1.31.amzn1.x86_64 (installed)
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
Error: Package: rpm-python27-4.11.3-21.75.amzn1.x86_64 (installed)
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
Error: Package: cyrus-sasl-2.1.23-13.16.amzn1.x86_64 (installed)
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
Error: Package: apr-util-1.5.4-6.18.amzn1.x86_64 (@amzn-main)
           Requires: libdb-4.7.so()(64bit)
           Removing: db4-4.7.25-18.11.amzn1.x86_64 (installed)
               libdb-4.7.so()(64bit)
           Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel)
              ~libdb-4.8.so()(64bit)
You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I tried using 'sudo yum clean all', but that didn't seem to fix the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.