0

If I have a nested bulleted list in Word, such as:

enter image description here

When I paste it into Notepad or any other plain text document, the bullets lose their indents:

enter image description here

How can I make the plain text version automatically keep the original spacing / indentations so that I don't need to manually go add spaces?

Ideally it would output Markdown like this.

To clarify: I'm asking how I can set the Copy operation of Word to understand to insert "tab" characters (which are plain text) into the values in the clipboard so that everything looks good when I paste.

  • As you have learned, your question is susceptible to misinterpretation.  Please edit your question to make it clearer and more complete; people are not going to read the comments on the answers to figure out what the question means. – Scott Jan 30 at 15:53
  • 1
    @Scott I'm really surprised it needed a clarification, but I edited the question. – Ryan Jan 30 at 15:55
  • You need to use a smarter text editor, for example the simple Wordpad. – harrymc Jan 30 at 16:56
  • @harrymc I just tried, and that did not work either. When I pasted from Word to WordPad and saved as .txt, the bullets and indents went away. Similarly, when I pasted from Word to WordPad and then copied and pasted from there to Notepad, the bullets and indents went away too. I'm not interested in destination file types of anything other than .txt. – Ryan Jan 30 at 18:35
  • You need support for the Rich Text format, which is just not available in .txt. If you want to copy the bullets in some other format, you will probably need a VBA macro, and not a simple one. – harrymc Jan 30 at 19:58
2

This does not seem possible in Microsoft Word

Open your document in Libreoffice Writer instead. Copy-pasting a list from Writer to a plain text editor keeps the correct indents and bullet points

• Content
    ◦ Nested content
• Content
    ◦ content 2.1
        ▪ content 2.1.1
            • content 2.1.1.1
  • Great idea! It worked! Thanks. – Ryan Mar 18 at 19:54
-2

Notepad.exe is a plain-text editor, it doesn't support Rich Text or HTML formatting.

  • I understand that. I'm asking how I can set the Copy operation of Word to understand to insert "tab" characters (which are plain text) into the values in the clipboard so that everything looks good when I paste. – Ryan Jan 30 at 15:21
  • Looking at the Copy & Paste options in word, it would appear not. – spikey_richie Jan 30 at 15:42
  • Not sure why this answer got -1'd, it's factually correct. – spikey_richie Feb 1 at 8:23
  • I'm tempted to -1 it too since it completely ignores that my question already shows that I understand what plain text is and am asking how to automatically include spaces. – Ryan Feb 2 at 1:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.