0

I bought USB flash drive last month, I'm sure it is USB 3.1. It was so fast that time.

This few days I notice it becomes so slow. 6GB data now takes 20-minutes during the transfer. And now when I tried to eject it, It says on label that it is USB 2.0.

I don't know how is that possible, when I bought this device from the label I am sure that it is USB 3.1.

Can anybody explain why it becomes USB 2.0? How can I make it USB 3.1 again?

All of my system’s USB ports are USB 3.1. I tried some of my other USB flash drives which are USB 3.1 too and they're all normal, except this one.

USB BRAND: Transcend, 16GB

OS: Windows 10

  • Please edit your question: You need to provide more details. Such as what OS you are using and what is the brand, model number and capacity of the USB flash drive. – JakeGould Jan 31 at 2:58
  • Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. – Ramhound Jan 31 at 3:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.