0

Update: I am trying to install sphinxbase. But after I cd to the sphinxbase directory and run ./autogen.sh, the terminal(cygwin) tells me:

Error: You must have `libtool' installed. Get ftp://ftp.gnu.org/pub/gnu/libtool/libtool-2.2.6b.tar.gz (or a newer version if it is available)

Error: You must have `automake' installed. Get ftp://ftp.gnu.org/pub/gnu/automake/automake-1.11.tar.gz (or a newer version if it is available)

I am using cygwin to execute the configure of automake under unzipped automake directory , but I encounter this:

User@6F-287202-NB-01 /cygdrive/c/Users/User/Desktop/cpythonworkspace/sphinx/automake-1.9

$ ./configure --build x86_64-pc-cygwin
  • checking build system type... x86_64-pc-cygwin checking for a

  • BSD-compatible install... /usr/bin/install -c checking whether build

  • environment is sane... yes checking for gawk... gawk checking whether

  • make sets $(MAKE)... ./configure: eval: line 1542: unexpected EOF

  • while looking for matching `"' ./configure: eval: line 1543: syntax

  • error: unexpected end of file

How to solve the unexpected EOF problem?

I open the configure file and jump to 1541th, 1542th line:

# GNU make sometimes prints "make1: Entering...", which would confuse us. eval `${MAKE-make} -f conftest.make 2>/dev/null | grep temp=`

notepad++ screenshot

7
  • Could you provide a link of that file? If you have Notepad++, can you provide a screenshot of that line with "show all symbol" enabled? – Biswapriyo Jan 31 '19 at 4:16
  • Please take a look at drive.google.com/file/d/15ObdfMXPRzw3JDHPdfh13eUYkSL5Yn9Y/…. I will install Notepad++ later – Cindy Jan 31 '19 at 4:20
  • For the notepad++ screenshot, drive.google.com/file/d/1cz98BULc20QHIZQdBnnXSLg9s6Xiz1P_/… – Cindy Jan 31 '19 at 4:25
  • python2-sphinx and python3-sphinx are available on cygwin. Why do you need to install from source ? – matzeri Jan 31 '19 at 7:08
  • @matzeri I am not sure if sphinx and cmu-sphinx are the same thing. Initially I guess that they are different. I am trying to install cmu-sphinxbase cmu-pocketsphinx. Can you give me some ideas? Thank you. – Cindy Jan 31 '19 at 7:12
0

Install libtool and automake with Cygwin setup.
You will need also python2-devel or python3-devel, gcc-core and swig

You can check after installation with:

$ cygcheck -cd libtool automake
Cygwin Package Information
Package              Version
automake             10-1
libtool              2.4.6-6

The package automake will pull all versions of automake 1.x available. If other packages are reported missing, check if they already available in cygwin https://cygwin.com/packages/package_list.html before trying to install by source. The following works without extra package from what available on cygwin

$ unzip sphinxbase-master.zip
$ cd sphinxbase-master
$ ./autogen.sh
**Warning**: I am going to run `configure' with no arguments.
If you wish to pass any to it, please specify them on the
`./autogen.sh' command line.

processing .
Running libtoolize...
...
config.status: executing libtool commands
Now type `make' to compile the package.
2
  • Thank you. What if the cygcheck command returns only header with empty content, what might be the problems( I restart the cygwin after installing)? – Cindy Jan 31 '19 at 8:30
  • I solved the abovee by using apt-cyg command; it's convenient. – Cindy Jan 31 '19 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.