0

i have used the following commands for node js installation

sudo apt install curl
curl -sL https://deb.nodesource.com/setup_10.x | sudo bash -
sudo apt install nodejs

3rd command gives the following error

The following packages have unmet dependencies: nodejs : Depends: python-minimal but it is not going to be installed E: Unable to correct problems, you have held broken packages.

i have found many solutions on the internet but none of them works for me, yes i am new to linux.

1

enter image description here Just reset the main repository to "Main server" of Ubuntu or another distribution of Linux and then run the below commands:

curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash -
sudo apt-get install -y nodejs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.