0

I have a problem. I found similar threads all over the internet, but I thought it might be better if I ask one specific with this configuration. There is a ubuntu 18 machine with 5x 4tb. I think it is raid5 (I did not install it, and the person who did is no longer here). There was a restart of the machine and since that I cannot assemble the raid.

To not make things worse, first I cloned the disks using

dd if=/dev/sdb of=sdb.iso bs=128k --status=progress

for sdb to sdf.

The first hint at an error might be, that sdb had an I/O Error after about 3TB.

I mounted them as loop devices and tried to assemble them:

mdadm: Cannot assemble mbr metadata on /dev/loop1
mdadm: /dev/loop1 has no superblock - assembly aborted

This is the same error as with the actual devices in the beginning.

mdadm --examine /dev/loop2

gives me

/dev/loop1:
   MBR Magic : aa55
Partition[0] :   4294967295 sectors at            1 (type ee)

This is exactly the same for all (loop) devices.

Also, assemble --force does not work.

Interestingly, if I use blkid, the result is:

/dev/sdb: PTUUID="1e34016b-9c4f-4c4d-a36d-50726c3df4b1" PTTYPE="gpt"
/dev/sdc: PTUUID="c4cd0051-37fc-4213-8e07-d63367040597" PTTYPE="gpt"
/dev/sdd: PTUUID="ed0aa999-48eb-45f3-9d92-a7b47d40d60a" PTTYPE="gpt"
/dev/sde: PTUUID="e8d707c1-55c0-493d-836e-58b55d922c35" PTTYPE="gpt"
/dev/sdf: PTUUID="8052a90c-140c-4ea1-a347-fd65109a97a6" PTTYPE="gpt"

I know from software raids that I created, that the TYPE should be "linux_raid_member".

I just noticed that in the kernel log, there are alot of events from 3 weeks ago like:

handle_parity_checks5: 327 callbacks suppressed
md0: mismatch sector in range 1911818256-1911818264

I read that if I use create it could just rewrite superblock data onto the drives. But for that I would need to know the parameters that were used when it was first created. Since it was not me, I don't know that. I would need to rely on defaults.

So, I guess I have two questions: Is there anything else I can try besides just recreating?

Is there some log where the creation parameters might be in?

Thx.

  • those are partition tables? try losetup --partscan then loopXpY partition device instead. – frostschutz Jan 31 at 10:25
  • There appear to be no partitions. losetup --partscan /dev/loop1p1 says "no suitable(? I have it in german) device found. – Pythoneer Jan 31 at 10:31
  • I detached the loop devices and attached them again usign losetup -P, but still only loop1 etc. Now loop1 (sdb) shows as /dev/loop1: PTTYPE="PMBR" – Pythoneer Jan 31 at 11:06

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.