0

I have a Rasberry Pi with two network interfaces.

One is a ppp interface connecting to a cellular modem over USB.

The other is a local ethernet connection with an ethernet cable connected to a local device.

The ppp interface works well when I start a systemd service to connect to it on boot-up.

However, as soon as I plug in the ethernet cable and boot the device, the eth0 interface and ppp both show up on ifconfig, but with the ppp interface I can not connect out to anything, for example ping 8.8.8.8 states that the destination is unreachable. If I plug out the ethernet cable tho again, it works fine.

Any idea what is going wrong here and why the two connections are not working at the same time? Thanks

`

0

When the ethernet cable is connected the device is getting a new default route which is being preferred, but is possibly invalid. You should be able to see/manipulate this with the route or ip route command.

  • Yes that's the problem. I can fix it with route add default gateway "address" . However this needs to be solved on startup automatically. No matter what I do. If I run the script from rc.local, .bashrc, insde rc5.d ,whatever, it never works for me unless i enter the command myself normally on the terminal after i log in – Engineer999 Feb 3 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.