On Windows 7, pressing Ctrl+Alt+Delete and selecting Task manager would almost always hide any full screen apps to the taskbar. In the case it didn't, it at least did put the task bar over the stuck application.

I had a stuck at loading on windows 10, and none of those tricks from Win7 worked. I could get into the Ctrl+Alt+Del menu. I could select Task manager, but the frozen program was still on fullscreen.

I eventually solved the issue by logging out, but that also closed other windows that I'd rather not have closed.

Is there an alternative to what I used to do on Windows 7? Maybe some registry fiddling would make the fullscreen mode more stable?

4 Answers 4


The usual way to get into and out of full screen mode is by using the F11 key.

If this does not work for you, try to hit Alt+Space to open the application menu and click (or use the keyboard) to choose Restore or Minimize.

Another way is to hit Ctrl+Shift+Esc to open the Task Manager. If it is still covered by the always-on-top full-screen program, press Alt+O to open its Options menu and then Enter to select Always on Top for the Task Manager.


This is a really common problem for me with games. The game will freeze and lock up the whole pc. I can open apps in the background, but the game is stuck displaying over everything and I can't access anything else because it takes priority visually over everything else. So far, the best solution for me came randomly a while ago. Press Windows Key + Tab and you will have the option to open another desktop instance. You can use this instance to close the frozen program using task manager.

  • [Windows]+[Tab] to create a new desktop really saved me here. The frozen game (Fallout76) would immediately claim focus the moment I opened task manager. On the new desktop I could open TM with no issues, to kill the Fallout process.
    – Cerbrus
    Commented May 8 at 10:18

Press Alt + F4. It closes the application.

Also you can press Alt + Space and select Close.

Also you can do task manager (Ctrl + Shift + Esc, Ctrl + Alt + Delete > Task manager).

If task manager does not come up press Alt + O and press Enter.

  • Did you read the question? It is about stuck programs that refuse to close and obscure the task manager.\ Commented Sep 14, 2023 at 8:38
  • "refuse to close" i didnt know that
    – someuser
    Commented Sep 15, 2023 at 20:31
  • yes but <kbd>alt+o</kbd><kbd>enter</kbd> works.
    – someuser
    Commented Sep 15, 2023 at 20:35
  • @someuser no, it doesn't. that assumes that app has system menu and it still processes events
    – Swift
    Commented Feb 23 at 12:17

If none of these other suggestions I have gotten a solution that may work. Try to drag the steam app more inward. This problem randomly occurs to people such as myself and a few others whereupon launching the steam app will automatically drag the windows borders to the edges of your screen looking as if you were in full screen mode. The easiest way to tell if this has happened to you is to press the fullscreen button on the top right of your screen. If the window does not look like it has been affected then you may possibly be encountering this bug.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .