0

I changed my laptop recently, used an Acer (Windows 7) and now I'm using a Samsung laptop with Windows 10. The thing is, I was using my older computer with another monitor (laptop monitor disabled) and a logitech keyboard. The keyboard has a power button, so I kept the lid closed and always waked the laptop with the button, without opening the lid, this way the laptop's monitor stayed disabled.

The new computer doesn't allow me to wake it up with the keyboard's power button. So every time I turn it on I need to open the lid, use the laptop's power button and then disable the monitor again in the windows display settings (even if I close the lid it stays on).

Already disabled the USB selective suspending setting. (It's a wireless keyboard)

Looked for the power management properties of the keyboard in the Device Manager, but this tab doesn't show up.

The keyboard doesn't appear in "powercfg -devicequery wake_from_any" list.

C:\Users\User>powercfg -devicequery wake_from_any

Realtek PCIe GBE Family Controller
Qualcomm Atheros AR9485WB-EG Wireless Network Adapter
ACPI Power Button
Microsoft Wi-Fi Direct Virtual Adapter
Microsoft Wi-Fi Direct Virtual Adapter #2
PCI-to-PCI Bridge
Intel(R) Management Engine Interface
PCI-to-PCI Bridge (001)

Still, the button can turn off the computer (sleep), it just can't wake it up.

Making this button work would really save me a lot of time...

Edit: The keyboard is a K270 and it's connected to the laptop with the same usb as the mouse.

Windows (device manager) says all keyboard and it's power button's (it shows up as a different device) drivers are up to date.

All three USB Root Hubs and the two Generic USB Hubs in the Device Managers got both options of Power Management tab unchecked:

Allow the computer to turn off this device to save power

Allow this device to wake the computer

But the last option (about waking up) is grayed out, can't change it. Maybe this is the problem?

  • Make sure you're plugged into the same USB port -- answers.microsoft.com/en-us/windows/forum/windows_7-hardware/… . Also could you be connecting via Bluetooth even though it's plugged into USB? It would help if you provided the keyboard make & model. – Debra Feb 2 at 19:51
  • Updated the post with the info – Dodilei Feb 2 at 22:21
  • Switching usb ports didn't change a thing... – Dodilei Feb 2 at 23:05
  • Ah, here's a thought: Go to Control Panel (display icons, not categories) > Device Manager (or whatever route you want to take to it). Go down to Keyboards, expand with +. Right-click your new keyboard & you should be able to checkmark the box to allow it to wake the system. – Debra Feb 5 at 2:57
  • Your comment solved my problem @Debra . Thank you everyone for helping me. – Dodilei Feb 7 at 23:14
0

Changing the config in the BIOS solved my problem, I don't remember the exact name now but it was wasy to find. It enables the "waking" of all USB ports at once and specifies the sleep state (S3) from wich the computer can be waken.

(I will update with more info next time I reboot my computer)

  • Since my problem was solved, is there a way to "close" this question? – Dodilei Feb 7 at 23:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.