2

How does one remove the BIOS password (I know the password)? The reason I am asking is that the BOOT priority on my laptop is messed up in my BIOS settings and installation disks are not booting now, it goes straight to the OS (can't access the BIOS menu anymore).

Laptop: Samsung NP300E5X
OS: Ubuntu 18.04

P.S.

Boot from CD/DWD and USB is not working currently. - main issue

sudo systemctl reboot --firmware-setup # will not work - system is not UEFI.

I can't enter BIOS pressing F2 before or after the password screen (right password). The F2 key is working fine - I can rename files with it, tested it as well here- w3keys, key-code 113 (F2)

UPDATE: 09/01/19

BIOS is not accessible w/ or w/o SSD. I was able to get into F10 (boot menu), it seems that having USB bootable inserted on system start + F10 did the trick (BIOS is still not available). However, the Boot Menu is empty with exception for "ubuntu" and App Menu is empty as well (image of the Boot Menu below). enter image description here

Screenshot of my SSD drive (it might be helpful). enter image description here

  • @VitaliyTerziev you haven't understood what I said about removing the hard drive. I'm not suggesting what harrymc said about removing the hard drive. I toold you that what harrymc said won't get you into the BIOS. Try plugging the or a hard drive into another laptop and put windows on it. There are ways 2 have windows on a hard drive in such a way that it will still run when the hard drive is moved to another computer. Apparetntly Acroniis can. alternatively there is another way too after windows is already installed. Then when u have windows on there,put the hard drive in ur laptop. – barlop Feb 6 at 20:53
  • @VitaliyTerziev Also, if the file will run from a DOS boot disk then it's arguably easier. You can go to another computer, plug your laptop's hard drive(or some hard drive) into it. Boot the other computer into a USB dos boot disk. Then do format H: /s (Where H is the drive letter of the laptop hard drive). The /s means system. Then plug your laptop's hard drive back into your laptop or in place of the current hard drive in your laptop. See if it boots to a DOS prompt. If it does then great. Then take it out , copy the BIOS update EXE file on there and try running it. – barlop Feb 6 at 21:01
  • 1
    @VitaliyTerziev The idea that putting a different hard drive in will let you F2 into the BIOS is absolutely ridiculous, please stop repeating that stupid idea. Do you seriously think that the BIOS can be so easily bypassed? Obviously if you put a new hard drive in and FLASH THE BIOS, then you may be able to get to the BIOS. But not just putting a new hard drive in. – barlop Feb 6 at 21:26
  • Have you tried F10 / FN + F10? – CraftyB Feb 8 at 9:16
  • 1
    @VitaliyTerziev Ah, didn't notice. It's very clear now, I'll delete my old comment, and this one after you read it (might as well keep the comments relatively neat ;-) – Xen2050 Feb 11 at 9:29
2
+25

There are two courses of action that you can take. As others have said, flashing your firmware is an option, but it may not be enough. Flashing the firmware is writing to its flash memory, rather than the CMOS, which stores the actual user configurations/settings. A good option here would be to reset, rather than flash, your firmware. This is done by opening up the computer and removing your CMOS battery. (Also, a misconception: this is the UEFI, not the BIOS; those are two completely different things).

A little bit of background: the CMOS is a type of RAM that needs constant power to store its settings. If it loses power, then it loses its changes and resets back to its defaults, which are hardcoded into the CMOS itself. Removing the CMOS battery is basically resetting it to factory defaults, but it is more foolproof than resetting it from your UEFI, which you cannot do anyway.

The process may vary from computer to computer, and you may have to crack open your case with force on some newer laptops. Make sure you have a grounding wristband or at least ground yourself before opening up the case, because static electricity can damage your motherboard (grounding wristbands are super cheap, you can find one readily on Amazon for $5). When you find the UEFI chip(s), the CMOS battery is somewhere around; it is a circular, almost flat, silver cylinder. Take it out gently (making sure you are grounded before), and wait for 5 minutes before inserting it back in.

Some motherboards have fixed CMOS batteries, however. These motherboards will most likely have a CMOS jumper that can reset it. Around the CMOS battery, there should be a jumper named CLEAR CMOS, PASSWORD, or something similar. Set it to the "clear" position, then move it back to where it originally was. Not all motherboards have this, though, and if you can't remove the CMOS battery as well, then you're pretty much stuck and can't use this method.

Reference this for a detailed explanation and pictures.

  • If it's a normal CMOS battery, make sure not to touch both sides of it at the same time and hold it at its edges when you have removed it, to not drain it. – Mikael Dúi Bolinder Feb 11 at 9:50
  • Make sure to remove the laptop battery as well, I had a laptop with easy access to the CMOS and tested the settings survived a CMOS pull if the laptop battery was inserted still. – FreeSoftwareServers Feb 11 at 23:11
  • See this thread Re: Removing CMOS to reset BIOS PWD. TLDR; It may not work and could break laptop. meta.superuser.com/questions/13568/… – FreeSoftwareServers Feb 11 at 23:39
  • Actually, I know of lots of anecdotal evidence of people breaking mobos because of attempting to remove the CMOS incorrectly. This, first of all, is anecdotal and is not based on real logic, just stories that may or may not be true. Second of all, CMOSes universally have an option to reset, whether it be removing the battery or using jumper cables like I mentioned in my answer. If they didn't, then every time a supervisor password was forgotten or a BIOS was flashed incorrectly, it would have to be taken to a store and time and money would be wasted. – Varun Narravula Feb 12 at 17:58
0

I believe you have gotten the BIOS itself somehow in a bad shape. Perhaps flashing it again will reset it to default values.

The BIOS for the NP300 is for the NP300E5A model, with this direct download link. If you may give me your exact model I could be more specific, as the one I found may not suite your computer model. This BIOS update dates from November 24, 2011, version 1.0.0.2.

The problem is that this BIOS is to be used with Windows and is distributed as an .exe file, so you will need a Windows environment for executing it.

You may create a bootable DOS USB using Rufus on Windows or UNetbootin for all major OS, then copy the BIOS update executable to the USB disk. You will need a DOS boot ISO file, you could maybe use SeaTools or find another one.

  • 1
    A)what do you mean when you say "you will need a Windows environment for executing it" AND yet you say "You may create a bootable DOS USB". How will the latter help in the case of the former? B)Furthermore, how can he boot off a DOS USB if he says "installation disks are not booting " implying he can't boot from any other drive? – barlop Feb 4 at 23:06
  • @harrymc you wrote "you can create a BIOS install USB as in my answer. If not, a repair-shop is the last solution" <-- Besides who are you to decide your idea is the final one. I guess you posted your non-answer to be final as well? And you do realise that a repair shop will often google problems and may even be reading suggestions here. There are people on this site that have worked in repair shops or been offered jobs in repair shops. Superuser would be a resource that they'd sometimes make use of. – barlop Feb 6 at 16:32
  • I'm not sure it's relevant. Have also a look at this one. – harrymc Feb 8 at 18:35
-1

On boot, you can try F12 or F8 or holding F10. (rather than F2)

Please see external link to discussion about various ways of getting into BIOS (source - ifixit.com).

Can't get to BIOS boot menu

  • Please quote and cite the relevant information from your link. – Ramhound Feb 9 at 0:34
-1

I see you've tried it without the SSD/HDD which I'd hope would afford you more time to hit key to get into BIOS. Glad to see you've also tried Fn+F2, but without luck :(

Have you tried an external keyboard? I see another Samsung (Tablet) PC has you hit ESC repeatedly

It seems you only gave us part of the PC model, can you give us more details? I can attest the difficulty of getting into BIOS on some brands since it stumped me for 15-30min & I've been in the industry for over a decade.

The first answer with a superuser link suggest external keyboard & F10 amongst other things, please take a look at that.

Edit: Looks like that first answer no longer exists. It pointed to this superuser answer about trying Esc or F10, also with external keyboard & spamming those keys on the internal & external keyboard simultaneously. That page has another answer seemingly pointing out this issue & it may not be resolvable :( Thanks Samsung!

Another idea: remove the SSD/HDD as you really SHOULD be able to get into the BIOS/UEFI-setup regardless if that is connected. I'd also do a static discharge if you can: remove power cord, battery, hold power button 20sec, reconnect things & try again. If you can't do static discharge at least hold power button down to be sure you're getting a full shut down since many of Samsung's guides (link 1 & 2) mention doing something like this.

  • 1
    It is important to note that the order answers appear is not the same for everyone. If you are going to reference another answer, you should cite and quote the relevant information, you feel is important. This way if the answer is delete, the information is still visible, and anyone can click on the link and be taken to the answer itself. – Ramhound Feb 9 at 0:36
  • gregg, thanks for your answer, I've added images plus some more info which was discussed in comments only so far. I think my keyboard is working fine not sure if this will help, I've tried all possible combinations I think, ESC will send me straight to GRUB. – Vitaliy Terziev Feb 9 at 1:02
  • @Ramhound I was on a smartphone browser so I couldn't easily do that, but thanks for the reminder especially considering it seems that answer was deleted. -VitaliyTerziev: ESC MAY send you to GRUB, however BIOS/UEFI is in control before it hands it off to the first sector of the HDD (GRUB) so it very much is a timing thing that is getting harder with newer/faster PC's. Since that was the key for a Tablet PC guessing it might not help, but worth the try. You can always yank out HDD so it doesn't go to GRUB to also try – gregg Feb 10 at 16:06
-1

Not every laptop will erase password with battery remove. I've met lenovo, which has unknown bios password that cannot be reset, via unpluggin battery, main battery and a PSU power cord for a day. As their admin said (somewhere on lenovo support forums, sorry cannot remember a link): "that is done to prevent device theft". But I feel more that it is done to tivoify their hardware, so only them can control users. For example - to embed trojans (like "Windows Update" trojan program) - any updater is a trojan program, which remotely installs and runs desired software. And also to performsome kind of user spying - eg "what apps you lanch", "what games you play", "what payment systems you use", "how many money you have there", so on...

Nowadays that is given under a "Know-Your-Customer" sauce, and is tied purely to marketing/advertisements (Which I feel is a industry close to terrorism: terror/narcotics/ads has essentially same goals: "hard user GANG").

So sometimes you cannot remove bios without soldering iron: you may have to look at instrucitions like these, with your model. But better sell this piece of.. hardware, and buy yourself a good hardware which is "unlocked"by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.