0

I've purchased a new SSD hard drive for my laptop. I put the SSD into the HDD's place and put the HDD into the DVD rom place. at first there was no problem, the computer detected both of them and they were listed in the boot option. when I tried to install windows on the SSD, it said that this drive is MBR and it should be GPT. I converted it to GPT using AOMEI, and tried to install the windows but it gave me this error

windows cannot install required files. the file may be corrupt or missing... error code :0x80070570

at first I thought that my device or the files had a problem. I tried with different windows files and different flash drives but the error occurred every time. then I realized that after I've changed the SSD type to GPT, it is not shown as a boot option in the boot menu. I converted it back to MBR, it came back to boot options!!

I formatted my old windows drive on the HDD, hoping that it would help, but it didn't! and now my HDD is not listed in boot options either!!

no GPT drive is being listed in my boot options. when I convert the SSD to MBR it is one of the boot options. and windows cannot be installed on an MBR drive. I can't even install windows on my old drive! it gives me the same error. I used to install windows 10 and others on this HDD without any problem and it is gpt. I don't know what to do! my bios is updated. my laptop is Asus x450cc

please help me!

  • You shouldn't have to convert from MBR to GPT. You should simply have unallocated space on the SSD, while booted in UEFI mode and install Windows onto the unallocated partition (this will create all require partitions for you). If you are creating partitions for the Windows installer you are doing something wrong. If you want GPT, you must disable Legacy Mode, when before attempting to boot into the installation environment. – Ramhound Feb 2 at 18:42
  • when I disable the legacy mode, it does not boot to the flash drive to install the windows! but I will check it with mbr as you said – Mohammad Talebi Feb 2 at 18:51
  • If it does not boot to the flash drive, then your installation media was not created to be compatible with UEFI mode. If that is the case, then you cannot use GPT and must use MBR. You could also create the media the correct way, I suggest, just using the Media Creation Tool. You are unable to install Windows, on a GPT disk, because your installation environment was booted while in Legacy Mode. – Ramhound Feb 2 at 18:54
  • windows installation is in progress now, hope it goes well! one question. why do you think my old HDD is not listed in the boot options now? – Mohammad Talebi Feb 2 at 19:00
  • as you said, I converted the SSD to MBR and unallocated it. windows installation started without saying that the drive should be GPT. but the same error occurred again! do you think my windows media has a problem? – Mohammad Talebi Feb 2 at 19:07
-1

it said that this drive is MBR and it should be GPT. I converted it to GPT using AOMEI, and tried to install the windows but it gave me this error

You only need to convert to GPT if you switched your BIOS to UEFI mode, but since from what I understand your BIOS is on Legacy mode which is incompatible with GPT and that caused the error.

no GPT drive is being listed in my boot options. when I convert the SSD to MBR it is one of the boot options. and windows cannot be installed on an MBR drive. I can't even install windows on my old drive! it gives me the same error. I used to install windows 10 and others on this HDD without any problem and it is gpt. I don't know what to do! my bios is updated. my laptop is Asus x450cc

You have 2 options:

  1. Convert your SSD to GPT, change BIOS to UEFI mode (to recognise your SSD) and then boot from it and install windows.
  2. Leave your SSD as MBR and boot from it to install windows.

P.S. In either situation, make sure the partition scheme and target system is compatible while creating the bootable flash drive. (i.e. GPT partition scheme for UEFI)

  • I can't choose the bios mode in the boot menu! there is no such option. I can only enable or disable the legacy USB support, or auto. – Mohammad Talebi Feb 2 at 19:20
  • Unlikely, your laptop isn't that old. What's your BIOS version? – NormalOsborn Feb 2 at 20:45
  • bios version is 210 – Mohammad Talebi Feb 3 at 4:58
  • Go to Boot tab and check for Boot Priorities or something similar. – NormalOsborn Feb 3 at 17:11
-1

thanks to Ramhound's help, the problem is solved! I was using Rufus to make a Bootable flash drive and it was not working right. I used another software and I was able to install the windows without any problem.

  • It would be a better answer if you tell us what software you actually used ... – DavidPostill Feb 3 at 18:13
  • I was using Rufus at first. I've installed several windows using Rufus without any problem, but this version had a problem, since it was not the same version as I used before. I made my flash drive Bootable for AOMEI using it successfully, but for the windows file, it was not working correctly. I tried WINFLASH and the problem was solved. – Mohammad Talebi Feb 10 at 19:53
  • So edit the answer please to include the extra information. – DavidPostill Feb 10 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.