0

I have created script for deleting old backups with wbadmin delete backup -keepVersions:10 and scheduled task to run with task scheduler. But this task scheduler is not working as this command prompts for Yes or no. How can i skip that?

3

According to this Article, you just need to add -quiet to your command.

wbadmin delete backup -keepVersions:10 -quiet

-quiet: Runs the subcommand with no prompts to the user.

  • I just saw that this documentation is about wbadmin start, not about wbadmin delete. Please still try it, it might work. – SimonS Feb 4 at 8:25
  • wdadmin delete also has -quiet flag. You just need to change the link in your answer to this one : docs.microsoft.com/en-us/windows-server/administration/… – lx07 Feb 4 at 9:22
  • @Nuhus great! Can you accept this answer by clicking the check mark icon next to the answer? Then others will know this question has been solved – SimonS Feb 5 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.