0

When I connect my USB keyboard, the keyboard isn't recognised (on all ports). (screenshot)

Most probably this is due to some recent Windows 10 Update (There was a previously reported issue for KB4074588 update that causes permission denied on port mapping).

My USB keyboard is fully functional as it's working with no problems on other computers. Also I tried, on my computer, different USB keyboards and they aren't working (except one old keyboard) and some USB mouses (except one old mouse) are the same not working.

My computer (Notebook) having the issue is HP EliteBook 8440p.
My current OS version is Windows 10 Enterprise 64-bit 17134.556.


I've tried these solution suggestions (none works):

  • Uninstalled all USB keyboard related drivers and restarted computer many times. (screenshot)
  • Made sure that drivers files on both my computer and other computers (where USB keyboards work normally) are identical.
    • All files of input.inf_amd64_d6b10f5fa055a5cd and keyboard.inf_amd64_e085085e52ff47cf folders in C:\Windows\System32\DriverStore\FileRepository are identical.
  • Tried to update drivers from device manager manually using input.inf_amd64_d6b10f5fa055a5cd and keyboard.inf_amd64_e085085e52ff47cf folders grabbed from other computers (where USB keyboards work normally). But I get The folder you specified doesn't contain a compatible software driver for your device.... (screenshot)
  • Tried reinstalling all official drivers for my computer. I have the latest version of Chipset driver is installed. (screenshot)
  • Disabled all Power Management on all USB hubs and input devices. I have made sure that USB selective suspend setting is Disabled both On battery and Plugged in. And that Power management is disabled (by unticking the Allow the computer to turn off this device to save power) on all related devices (USB Hubs and USB input devices). (screenshot)
  • System Restore. Unfortunately I don't have a System Restore image for my OS before the issue.
  • Uninstalling recent OS updates. I have uninstalled all recent OS updates that I can uninstall and the issue still exists.
    • I've tried dism /online /remove-package /packagename:Package_for_RollupFix~31bf3856ad364e35~amd64~~16299.248.1.17 command to uninstall KB4074588 update, but I get error 0x800f0805 The specified package is not valid Windows package. (screenshot)
  • Updating to the most recent updates.
  • Tried Keyboard Troubleshoot, but it gives me No changes or updates were necessary. (screenshot)
  • Checked for errors in OS files using DISM Restorehealth and sfc, then restarted multiple times and issue still not solved. (screenshot)
  • Confirmed that all keyboard-related services are running. (screenshot)
    • I used Device Remover to search and list any keyboard related service.
    • I wasn't able to start a service named HpqKbFiltr

I need to solve this issue without reinstalling a fresh copy of Windows 10.

  • Use a Live Linux to identify whether this is perhaps a hardware issue. – Daniel B Feb 8 at 11:48
  • I have tried Live Linux and it actually showed the same problem that was on Windows :( . It seems that the problem is with the USB ports hardware. Is there any chance that the problem is due to some Software problem (may be some BIOS setting or so on).? Also kindly note that my USB ports are able to function usb mass storage with no problems (just keyboards and some mouses doesn't function on any) (only one very old heavy USB keyboard which works with no problems on any of the ports, also there's another USB keyboard that sometimes works well and other times shows lag.) – Omar Feb 8 at 16:25
  • I'm sure that all the keyboards and mice being tested are fully functional on other computers. On my computer (both on Linux and Windows) many if them don't work at all, and just one mouse (DELL) works well, and one old keyboard (ACER) works very well, and one keyboard (DELL) sometimes works well and sometimes shows weird behaviour between lagging or inputting keys many times more than needed. – Omar Feb 8 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.