0

I am attempting to run Theano through Spyder on my Windows 10 Machine. I have a GTX 1070, and have installed CUDA 10, 9, 8, 7 with their respective cudnn files and patches (I'm new to this and have very little idea on what I need to do).

It throws the error:

ERROR (theano.gpuarray): Could not initialize pygpu, support disabled
Traceback (most recent call last):
  File "C:\Users\liamf\Anaconda2\lib\site-packages\theano\gpuarray\__init__.py", line 227, in <module>
    use(config.device)
  File "C:\Users\liamf\Anaconda2\lib\site-packages\theano\gpuarray\__init__.py", line 214, in use
    init_dev(device, preallocate=preallocate)
  File "C:\Users\liamf\Anaconda2\lib\site-packages\theano\gpuarray\__init__.py", line 121, in init_dev
    dnn.dnn_available.msg)
RuntimeError: You enabled cuDNN, but we aren't able to use it: cannot compile with cuDNN. We got this error:
In file included from C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v8.0\include/driver_types.h:53:0,
                 from C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v8.0\include/cudnn.h:63,
                 from c:\users\liamf\appdata\local\temp\try_flags_agqfck.c:4:
C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v8.0\include/host_defines.h:84:0: warning: "__cdecl" redefined
 #define __cdecl
 ^
<built-in>: note: this is the location of the previous definition
C:/Users/liamf/Anaconda2/Library/mingw-w64/bin/../lib/gcc/x86_64-w64-mingw32/5.3.0/../../../../x86_64-w64-mingw32/bin/ld.exe: cannot find -lcudnn
collect2.exe: error: ld returned 1 exit status

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.