0

I'm trying to configure Wake-On-Lan on a computer. Here is what I've done:

  1. enabled it in BIOS (Power on by PME: Allows you to turn on the system through a PCI/PCIE/onboard LAN device).
    Note: I'm using a PCI ethernet card.
    Note2: motherboard: ASUS M4A79XTO EVO manual.

  2. enabled it via Linux with sudo ethtool -s eth0 wol g, then when using sudo ethtool eth0, I see:

    Supports Wake-on: pumbg
    Wake-on: g
    

    which seems to confirm it's ok.

  3. either shutdown the computer with sudo halt -p or suspend with systemctl suspend or hibernate (I tested all of them)

  4. send the magic packet from another Windows computer on the same local network using WakeMeOnLan by specifying the right IP address + MAC address

  5. but nothing happens!

Fact: when I hibernate or suspend or turn off, the LED of the ethernet card is off. Is it the same for you who successfully use WakeOnLan? Is it normal that the green LED is off (usually saying that the network is no more connected)?

More generally, what could cause the WoL to fail?

  • Making it work can be a real struggle, and it is also dependent on your hardware. You will find an account of such a struggle in the Debian Wiki Wake On LAN. Follow this article and let us know what happened by editing your post. If using Arch Linux see this article. – harrymc Nov 17 '19 at 18:32
  • @harrymc Just to be sure: does WOL wake from "computer off" state or from "hibernate" state? – Basj Nov 17 '19 at 19:26
  • I know that Windows needs to be in Sleep, not Hibernate, for WOL. On Linux there are too many distributions and drivers to speculate. To be safe, use Sleep. – harrymc Nov 17 '19 at 19:32
  • Ok so on Windows: Sleep: OK, Hibernate: not OK, Power off: not OK, is that right? – Basj Nov 17 '19 at 19:53
  • 1
    "Ok so on Windows: Sleep: OK, Hibernate: not OK, Power off: not OK, is that right?" - that's completely wrong. Wake on LAN absolutely wakes PCs from hibernate and off power states. I use it all the time. – Mr Ethernet Nov 23 '19 at 23:25
0

I replaced my motherboard with a new one (Asus M5A78L) and I'm now using the built-in LAN adapter, instead of a PCI Ethernet card.

Now Wake-On-Lan works out of the box from all these states:

  • shutdown -h now
  • systemctl hibernate
  • systemctl suspend
| improve this answer | |
  • 1
    You can also generally wake Windows computers from sleep, hibernate and off power states, not only sleep. It's easy enough to make it work, you just need to enable it in both the BIOS and NIC driver. – Mr Ethernet Nov 23 '19 at 23:29
  • That depends a lot on the hardware. – harrymc Nov 24 '19 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.