So today I started my Windows Server 2008 R2 virtual machine and got an error saying this:

Result Code:  E_FAIL (0x80004005)
Component:    MachineWrap
Interface:    IMachine {5047460a-265d-4538-b23e-ddba5fb84976}

And I did take a look on the VBoxHardening.log file. I noticed several lines about crypt32.dll. But I didn't found any information about this problem on Windows 10, and I tried to reinstall VirtualBox three times. Then I checked my crypt32.dll file and it's certificate was expired.

I changed the date on computer to 05.08.2018 and it worked. But it's temporary solution as changing the date breaks many other certificates.
I'm running Windows 10 Pro (build 1809).

Here is the error in VBoxHardening.log:

1268.143c: Fatal error:
1268.143c: Error loading 'crypt32.dll': 1790 [C:\WINDOWS\system32\crypt32.dll]
52c.2528: supR3HardNtChildWaitFor[2]: Quitting: ExitCode=0x1 (rcNtWait=0x0, rcNt1=0x0, rcNt2=0x103, rcNt3=0x103, 658 ms, the end);
2f14.1988: supR3HardNtChildWaitFor[1]: Quitting: ExitCode=0x1 (rcNtWait=0x0, rcNt1=0x0, rcNt2=0x103, rcNt3=0x103, 1156 ms, the end);
  • What version of VirtualBox? – Kinnectus Feb 5 '19 at 15:25
  • @Kinnectus last, 6.0.4 – dengr1065 Feb 5 '19 at 15:26
  • Also I don't think there's something to do with VirtualBox. crypt32.dll's certificate is expired. – dengr1065 Feb 5 '19 at 15:28
  • Can you post the VBoxHardening.log lines where the file is rejected? – Kinnectus Feb 5 '19 at 15:39
  • 1
    @Kinnectus already did it, nothing changed (I rebooted after scan) – dengr1065 Feb 5 '19 at 15:48

I forgot that I have an Windows 10 ISO. So here's what I did.

First, I mounted the ISO by double-clicking on it.
Then, I opened sources\install.wim file using 7-zip.
I navigated to 1\Windows\system32\ and copied the crypt32.dll file.
Checked digital signature and it was valid.
Then I did reboot to recovery mode with command line, made a backup and replaced the file using these commands:

cd WINDOWS\system32
mv crypt32.dll crypt32.dll.bak
mv C:\Users\<username>\Desktop\crypt32.dll crypt32.dll

I closed the Command Line window and did reboot to normal mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.