1

I am working with excel a lot. I wonder why sometimes it starts eating 50+% of my CPU slowing everything down even when no calculation of formulas is happening and I didn't start any action! Funny thing is that usually this stops when I close one of the opened workbooks and it absolutely doesn't matter which one. Even some which I opened 2 hours ago and didn't touch since - if I close it then suddenly Excel stops being crazy and is usable again!

The almost guaranteed way to make Excel super slow and overload CPU is a simple pressing of Ctrl+C. Things don't get calm until I paste it somewhere or press Esc which is quite often very hard when everything reacts so slow at that time. It happens to me and my colleague as well with various workbooks and it does not seem to be related to any specific file as we work with many and create many. Any ideas?

1
  • So I have spent a long time reading some forum threads with various suggestions and today after few hours of working it looks like fixed. I have checked "disable hardware graphics acceleration" in options / advanced / display. I will confirm after few days and make this an answer. However my colleague didn't confirm this helps in his case ...
    – Vitas
    Feb 7 '19 at 11:47
0

Go to options / advanced / display - and check "disable hardware graphics acceleration" This helps on my system Thinkpad T460: with core i5-6300U. However this is NOT a universal solution as my colleague with T470 core i5-7300U tried it and it does not have any effect :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.